wrs_release_br2_config 67.5 KB
Newer Older
1
#
2 3
# Automatically generated file; DO NOT EDIT.
# Buildroot 2016.02 Configuration
4 5
#
BR2_HAVE_DOT_CONFIG=y
6 7 8 9 10 11 12 13

#
# Target options
#
BR2_SOFT_FLOAT=y
BR2_ARCH_HAS_MMU_OPTIONAL=y
# BR2_arcle is not set
# BR2_arceb is not set
14 15
BR2_arm=y
# BR2_armeb is not set
16 17
# BR2_aarch64 is not set
# BR2_aarch64_be is not set
18
# BR2_bfin is not set
19
# BR2_i386 is not set
20 21
# BR2_microblazeel is not set
# BR2_microblazebe is not set
22 23
# BR2_mips is not set
# BR2_mipsel is not set
24 25 26
# BR2_mips64 is not set
# BR2_mips64el is not set
# BR2_nios2 is not set
27
# BR2_powerpc is not set
28 29
# BR2_powerpc64 is not set
# BR2_powerpc64le is not set
30 31
# BR2_sh is not set
# BR2_sparc is not set
32
# BR2_sparc64 is not set
33 34
# BR2_x86_64 is not set
# BR2_xtensa is not set
35 36 37 38 39 40 41 42 43 44 45 46
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"
BR2_GCC_TARGET_ABI="aapcs-linux"
BR2_GCC_TARGET_CPU="arm926ej-s"
BR2_GCC_TARGET_FLOAT_ABI="soft"
BR2_GCC_TARGET_MODE="arm"
BR2_BINFMT_SUPPORTS_SHARED=y
BR2_BINFMT_ELF=y
BR2_ARM_CPU_MAYBE_HAS_VFPV2=y
BR2_ARM_CPU_HAS_ARM=y
BR2_ARM_CPU_HAS_THUMB=y
BR2_ARM_CPU_ARMV5=y
47
# BR2_arm920t is not set
48
# BR2_arm922t is not set
49
BR2_arm926t=y
50
# BR2_arm1136j_s is not set
51 52 53
# BR2_arm1136jf_s is not set
# BR2_arm1176jz_s is not set
# BR2_arm1176jzf_s is not set
54 55 56
# BR2_arm11mpcore is not set
# BR2_cortex_a5 is not set
# BR2_cortex_a7 is not set
57
# BR2_cortex_a8 is not set
58
# BR2_cortex_a9 is not set
59 60 61 62 63 64
# BR2_cortex_a12 is not set
# BR2_cortex_a15 is not set
# BR2_cortex_m3 is not set
# BR2_fa526 is not set
# BR2_pj4 is not set
# BR2_strongarm is not set
65 66
# BR2_xscale is not set
# BR2_iwmmxt is not set
67
# BR2_ARM_ENABLE_VFP is not set
68
BR2_ARM_EABI=y
69 70 71
BR2_ARM_SOFT_FLOAT=y
BR2_ARM_INSTRUCTIONS_ARM=y
# BR2_ARM_INSTRUCTIONS_THUMB is not set
72 73

#
74
# Build options
75 76 77
#

#
78
# Commands
79
#
80 81 82 83
BR2_WGET="wget --passive-ftp -nd -t 3"
BR2_SVN="svn"
BR2_BZR="bzr"
BR2_GIT="git"
84
BR2_CVS="cvs"
85
BR2_LOCALFILES="cp"
86 87 88
BR2_SCP="scp"
BR2_SSH="ssh"
BR2_HG="hg"
89 90
BR2_ZCAT="gzip -d -c"
BR2_BZCAT="bzcat"
91
BR2_XZCAT="xzcat"
92
BR2_TAR_OPTIONS=""
93
BR2_DEFCONFIG="$(CONFIG_DIR)/defconfig"
94 95
BR2_DL_DIR="$(TOPDIR)/../../downloads"
BR2_HOST_DIR="$(BASE_DIR)/host"
96 97 98 99 100

#
# Mirrors and Download locations
#
BR2_PRIMARY_SITE=""
101
BR2_BACKUP_SITE="http://sources.buildroot.net/"
102 103
BR2_KERNEL_MIRROR="http://www.kernel.org/pub/"
BR2_GNU_MIRROR="http://ftp.gnu.org/pub/gnu"
104 105
BR2_LUAROCKS_MIRROR="http://rocks.moonscript.org"
BR2_CPAN_MIRROR="http://cpan.metacpan.org"
106
BR2_JLEVEL=0
107
# BR2_CCACHE is not set
108 109 110 111
# BR2_DEPRECATED is not set
# BR2_ENABLE_DEBUG is not set
BR2_STRIP_strip=y
# BR2_STRIP_none is not set
112 113
BR2_STRIP_EXCLUDE_FILES=""
BR2_STRIP_EXCLUDE_DIRS=""
114 115
# BR2_OPTIMIZE_0 is not set
# BR2_OPTIMIZE_1 is not set
116
# BR2_OPTIMIZE_2 is not set
117
# BR2_OPTIMIZE_3 is not set
118
BR2_OPTIMIZE_S=y
119 120 121 122 123 124 125

#
# Stack Smashing Protection needs a toolchain w/ SSP
#
# BR2_STATIC_LIBS is not set
BR2_SHARED_LIBS=y
# BR2_SHARED_STATIC_LIBS is not set
126
BR2_PACKAGE_OVERRIDE_FILE="$(TOPDIR)/local.mk"
127 128 129 130 131 132
BR2_GLOBAL_PATCH_DIR=""

#
# Advanced
#
BR2_COMPILER_PARANOID_UNSAFE_PATH=y
133 134 135 136

#
# Toolchain
#
137 138
BR2_TOOLCHAIN=y
BR2_TOOLCHAIN_USES_UCLIBC=y
139 140
BR2_TOOLCHAIN_BUILDROOT=y
# BR2_TOOLCHAIN_EXTERNAL is not set
141
BR2_TOOLCHAIN_BUILDROOT_VENDOR="buildroot"
142 143 144 145

#
# Kernel Header Options
#
146 147 148 149 150 151 152 153
# BR2_KERNEL_HEADERS_3_2 is not set
# BR2_KERNEL_HEADERS_3_4 is not set
# BR2_KERNEL_HEADERS_3_10 is not set
# BR2_KERNEL_HEADERS_3_12 is not set
# BR2_KERNEL_HEADERS_3_14 is not set
# BR2_KERNEL_HEADERS_3_18 is not set
# BR2_KERNEL_HEADERS_4_1 is not set
# BR2_KERNEL_HEADERS_4_3 is not set
154 155
# BR2_KERNEL_HEADERS_4_4 is not set
BR2_KERNEL_HEADERS_VERSION=y
156
BR2_DEFAULT_KERNEL_VERSION="3.16.38"
157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_4 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_3 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_2 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_1 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_4_0 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_19 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_18 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_17 is not set
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_16=y
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_15 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_14 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_13 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_12 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_11 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_10 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_9 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_8 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_7 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_6 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_5 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_4 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_3 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_2 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_1 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_0 is not set
# BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_REALLY_OLD is not set
183
BR2_DEFAULT_KERNEL_HEADERS="3.16.38"
184 185 186 187 188 189
BR2_TOOLCHAIN_BUILDROOT_UCLIBC=y
# BR2_TOOLCHAIN_BUILDROOT_GLIBC is not set
# BR2_TOOLCHAIN_BUILDROOT_MUSL is not set
BR2_TOOLCHAIN_BUILDROOT_LIBC="uclibc"
BR2_PACKAGE_LINUX_HEADERS=y
BR2_PACKAGE_UCLIBC=y
190 191 192 193

#
# uClibc Options
#
194 195 196 197 198 199 200 201
BR2_UCLIBC_CONFIG="package/uclibc/uClibc-ng.config"
BR2_UCLIBC_CONFIG_FRAGMENT_FILES=""
BR2_TOOLCHAIN_BUILDROOT_INET_RPC=y
BR2_TOOLCHAIN_BUILDROOT_WCHAR=y
# BR2_TOOLCHAIN_BUILDROOT_LOCALE is not set
# BR2_PTHREADS_NONE is not set
# BR2_PTHREADS_OLD is not set
BR2_PTHREADS_NATIVE=y
202
BR2_PTHREAD_DEBUG=y
203 204
# BR2_TOOLCHAIN_BUILDROOT_USE_SSP is not set
BR2_UCLIBC_INSTALL_UTILS=y
205
# BR2_UCLIBC_INSTALL_TEST_SUITE is not set
206 207
BR2_UCLIBC_TARGET_ARCH="arm"
BR2_UCLIBC_ARM_BX=y
208 209 210 211

#
# Binutils Options
#
212 213 214 215
# BR2_BINUTILS_VERSION_2_23_X is not set
BR2_BINUTILS_VERSION_2_24_X=y
# BR2_BINUTILS_VERSION_2_25_X is not set
BR2_BINUTILS_VERSION="2.24"
216
BR2_BINUTILS_EXTRA_CONFIG_OPTIONS=""
217 218 219 220

#
# GCC Options
#
221 222 223 224 225 226
BR2_GCC_NEEDS_MPC=y
BR2_GCC_SUPPORTS_GRAPHITE=y
# BR2_GCC_VERSION_4_7_X is not set
# BR2_GCC_VERSION_4_8_X is not set
BR2_GCC_VERSION_4_9_X=y
# BR2_GCC_VERSION_5_X is not set
227
BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE=y
228
BR2_GCC_VERSION="4.9.3"
229
BR2_EXTRA_GCC_CONFIG_OPTIONS=""
230 231
# BR2_TOOLCHAIN_BUILDROOT_CXX is not set
# BR2_TOOLCHAIN_BUILDROOT_FORTRAN is not set
232
BR2_GCC_ENABLE_TLS=y
233
# BR2_GCC_ENABLE_LTO is not set
234
# BR2_GCC_ENABLE_OPENMP is not set
235 236 237 238
# BR2_GCC_ENABLE_GRAPHITE is not set
# BR2_PACKAGE_HOST_GDB is not set
BR2_GDB_VERSION="7.9.1"
BR2_TOOLCHAIN_HAS_NATIVE_RPC=y
239
BR2_USE_WCHAR=y
240
BR2_TOOLCHAIN_HAS_THREADS=y
241 242
BR2_TOOLCHAIN_HAS_THREADS_DEBUG=y
BR2_TOOLCHAIN_HAS_THREADS_NPTL=y
243
BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS=y
244
# BR2_ENABLE_LOCALE_PURGE is not set
245 246 247 248
BR2_NEEDS_GETTEXT=y
BR2_USE_MMU=y
BR2_TARGET_OPTIMIZATION="-pipe"
BR2_TARGET_LDFLAGS=""
249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266
# BR2_ECLIPSE_REGISTER is not set
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_1=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_2=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_3=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_4=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_5=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_6=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_7=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_8=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_9=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_11=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_13=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_14=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_15=y
BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_16=y
267
BR2_TOOLCHAIN_HEADERS_AT_LEAST="3.16"
268 269 270 271 272 273 274 275 276 277 278 279
BR2_TOOLCHAIN_GCC_AT_LEAST_4_3=y
BR2_TOOLCHAIN_GCC_AT_LEAST_4_4=y
BR2_TOOLCHAIN_GCC_AT_LEAST_4_5=y
BR2_TOOLCHAIN_GCC_AT_LEAST_4_6=y
BR2_TOOLCHAIN_GCC_AT_LEAST_4_7=y
BR2_TOOLCHAIN_GCC_AT_LEAST_4_8=y
BR2_TOOLCHAIN_GCC_AT_LEAST_4_9=y
BR2_TOOLCHAIN_GCC_AT_LEAST="4.9"
BR2_TOOLCHAIN_HAS_SYNC_1=y
BR2_TOOLCHAIN_HAS_SYNC_2=y
BR2_TOOLCHAIN_HAS_SYNC_4=y
BR2_TOOLCHAIN_HAS_ATOMIC=y
280 281 282 283 284

#
# System configuration
#
BR2_TARGET_GENERIC_HOSTNAME="wrs3"
285
BR2_TARGET_GENERIC_ISSUE="Welcome to WR Switch V3"
286 287 288 289 290 291 292 293 294 295 296
BR2_TARGET_GENERIC_PASSWD_MD5=y
# BR2_TARGET_GENERIC_PASSWD_SHA256 is not set
# BR2_TARGET_GENERIC_PASSWD_SHA512 is not set
BR2_TARGET_GENERIC_PASSWD_METHOD="md5"
BR2_INIT_BUSYBOX=y
# BR2_INIT_SYSV is not set

#
# systemd needs (e)glibc toolchain, headers >= 3.10
#
# BR2_INIT_NONE is not set
297 298
# BR2_ROOTFS_DEVICE_CREATION_STATIC is not set
# BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_DEVTMPFS is not set
299
BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV=y
300 301
# BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV is not set
BR2_ROOTFS_DEVICE_TABLE="system/device_table.txt"
302 303
BR2_ROOTFS_SKELETON_DEFAULT=y
# BR2_ROOTFS_SKELETON_CUSTOM is not set
304 305 306 307 308 309 310 311 312 313
# BR2_ROOTFS_MERGED_USR is not set
BR2_TARGET_ENABLE_ROOT_LOGIN=y
BR2_TARGET_GENERIC_ROOT_PASSWD=""
BR2_SYSTEM_BIN_SH_BUSYBOX=y
# BR2_SYSTEM_BIN_SH_BASH is not set
# BR2_SYSTEM_BIN_SH_DASH is not set
# BR2_SYSTEM_BIN_SH_ZSH is not set
# BR2_SYSTEM_BIN_SH_NONE is not set
BR2_SYSTEM_BIN_SH="busybox"
BR2_TARGET_GENERIC_GETTY=y
314 315 316 317 318 319 320 321
BR2_TARGET_GENERIC_GETTY_PORT="ttyS0"
# BR2_TARGET_GENERIC_GETTY_BAUDRATE_KEEP is not set
# BR2_TARGET_GENERIC_GETTY_BAUDRATE_9600 is not set
# BR2_TARGET_GENERIC_GETTY_BAUDRATE_19200 is not set
# BR2_TARGET_GENERIC_GETTY_BAUDRATE_38400 is not set
# BR2_TARGET_GENERIC_GETTY_BAUDRATE_57600 is not set
BR2_TARGET_GENERIC_GETTY_BAUDRATE_115200=y
BR2_TARGET_GENERIC_GETTY_BAUDRATE="115200"
322 323
BR2_TARGET_GENERIC_GETTY_TERM="vt100"
BR2_TARGET_GENERIC_GETTY_OPTIONS=""
324
BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW=y
325 326 327 328
BR2_SYSTEM_DHCP=""
# BR2_TARGET_TZ_INFO is not set
BR2_ROOTFS_USERS_TABLES=""
BR2_ROOTFS_OVERLAY=""
329
BR2_ROOTFS_POST_BUILD_SCRIPT=""
330
BR2_ROOTFS_POST_IMAGE_SCRIPT=""
331 332

#
333
# Kernel
334
#
335
# BR2_LINUX_KERNEL is not set
336 337

#
338
# Target packages
339
#
340 341 342 343 344 345 346
BR2_PACKAGE_BUSYBOX=y
BR2_PACKAGE_BUSYBOX_CONFIG="__WR_SWITCH_SW__/wrs_release_busybox_config"
BR2_PACKAGE_BUSYBOX_CONFIG_FRAGMENT_FILES=""
BR2_PACKAGE_BUSYBOX_SHOW_OTHERS=y
# BR2_PACKAGE_BUSYBOX_SELINUX is not set
# BR2_PACKAGE_BUSYBOX_WATCHDOG is not set
BR2_PACKAGE_SKELETON=y
347 348

#
349
# Audio and video applications
350
#
351
# BR2_PACKAGE_ALSA_UTILS is not set
352
# BR2_PACKAGE_AUMIX is not set
353 354

#
355
# bellagio needs a toolchain w/ C++, threads, dynamic library
356
#
357 358
# BR2_PACKAGE_DVBLAST is not set
# BR2_PACKAGE_DVDAUTHOR is not set
359 360

#
361
# dvdrw-tools needs a toolchain w/ threads, C++, wchar
362 363 364
#

#
365
# espeak needs a toolchain w/ C++, wchar, threads, dynamic library
366
#
367 368 369 370 371 372
# BR2_PACKAGE_FAAD2 is not set
# BR2_PACKAGE_FFMPEG is not set
# BR2_PACKAGE_FLAC is not set
# BR2_PACKAGE_FLITE is not set
# BR2_PACKAGE_GSTREAMER is not set
# BR2_PACKAGE_GSTREAMER1 is not set
373 374

#
375
# jack2 needs a toolchain w/ threads, C++, dynamic library
376
#
377
BR2_PACKAGE_KODI_ARCH_SUPPORTS=y
378 379

#
380
# kodi needs a toolchain w/ C++, threads, wchar, dynamic library
381 382 383
#

#
384
# kodi requires an OpenGL ES and EGL backend
385
#
386
# BR2_PACKAGE_LAME is not set
387
# BR2_PACKAGE_MADPLAY is not set
388 389

#
390
# miraclecast needs systemd and a glibc toolchain w/ threads and wchar
391 392 393
#

#
394
# mjpegtools needs a toolchain w/ C++, threads
395 396 397
#

#
398
# modplugtools needs a toolchain w/ C++
399 400 401
#

#
402
# mpd needs a toolchain w/ C++, threads, wchar, gcc >= 4.6
403
#
404 405 406 407 408 409
# BR2_PACKAGE_MPD_MPC is not set
# BR2_PACKAGE_MPG123 is not set
BR2_PACKAGE_MPLAYER_ARCH_SUPPORTS=y
# BR2_PACKAGE_MPLAYER is not set
# BR2_PACKAGE_MUSEPACK is not set
# BR2_PACKAGE_NCMPC is not set
410 411

#
412
# on2-8170-libs needs an (e)glibc toolchain and a Linux kernel to be built
413
#
414 415 416 417
# BR2_PACKAGE_OPUS_TOOLS is not set
# BR2_PACKAGE_PULSEAUDIO is not set
# BR2_PACKAGE_SOX is not set
# BR2_PACKAGE_SQUEEZELITE is not set
418 419

#
420
# tovid needs a toolchain w/ threads, C++, wchar
421 422 423
#

#
424
# tovid depends on python or python3
425
#
426 427
# BR2_PACKAGE_TSTOOLS is not set
# BR2_PACKAGE_TWOLAME is not set
428 429

#
430
# upmpdcli needs a toolchain w/ C++, threads, gcc >= 4.6
431 432 433
#

#
434
# v4l2grab needs a toolchain w/ threads, dynamic library, C++ and headers >= 3.0
435 436 437
#

#
438
# vlc needs a toolchain w/ C++, dynamic library, wchar, threads, headers >= 3.7
439
#
440 441 442 443
# BR2_PACKAGE_VORBIS_TOOLS is not set
# BR2_PACKAGE_WAVPACK is not set
# BR2_PACKAGE_YAVTA is not set
# BR2_PACKAGE_YMPD is not set
444 445

#
446
# Compressors and decompressors
447
#
448 449 450
# BR2_PACKAGE_BZIP2 is not set
# BR2_PACKAGE_GZIP is not set
# BR2_PACKAGE_LZ4 is not set
451 452

#
453
# lzip needs a toolchain w/ C++
454
#
455
# BR2_PACKAGE_LZOP is not set
456 457

#
458
# unrar needs a toolchain w/ C++, wchar, threads
459
#
460 461 462
# BR2_PACKAGE_UNZIP is not set
# BR2_PACKAGE_XZ is not set
# BR2_PACKAGE_ZIP is not set
463 464

#
465
# Debugging, profiling and benchmark
466 467 468
#

#
469
# blktrace needs a (e)glibc or musl toolchain
470 471 472
#

#
473
# bonnie++ needs a toolchain w/ C++
474
#
475 476 477 478 479
# BR2_PACKAGE_CACHE_CALIBRATOR is not set
# BR2_PACKAGE_DHRYSTONE is not set
# BR2_PACKAGE_DMALLOC is not set
# BR2_PACKAGE_DROPWATCH is not set
# BR2_PACKAGE_DSTAT is not set
480 481

#
482
# duma needs a toolchain w/ C++, threads, dynamic library
483
#
484 485 486 487 488 489
# BR2_PACKAGE_FIO is not set
BR2_PACKAGE_GDB=y
BR2_PACKAGE_GDB_SERVER=y
BR2_PACKAGE_GDB_DEBUGGER=y
BR2_PACKAGE_GDB_TUI=y
BR2_PACKAGE_GOOGLE_BREAKPAD_ARCH_SUPPORTS=y
490 491

#
492
# google-breakpad requires an (e)glibc toolchain w/ C++ enabled
493
#
494 495
# BR2_PACKAGE_IOZONE is not set
# BR2_PACKAGE_KEXEC is not set
496 497

#
498
# ktap needs a Linux kernel to be built
499
#
500 501 502 503 504 505
# BR2_PACKAGE_LATENCYTOP is not set
# BR2_PACKAGE_LMBENCH is not set
BR2_PACKAGE_LSOF=y
# BR2_PACKAGE_LTP_TESTSUITE is not set
BR2_PACKAGE_LTRACE=y
# BR2_PACKAGE_LTTNG_BABELTRACE is not set
506 507

#
508
# lttng-modules needs a Linux kernel to be built
509
#
510 511 512
# BR2_PACKAGE_LTTNG_TOOLS is not set
# BR2_PACKAGE_MEMSTAT is not set
# BR2_PACKAGE_NETPERF is not set
513 514

#
515
# netsniff-ng needs an (e)glibc toolchain w/ threads, headers >= 3.0
516 517 518
#

#
519
# oprofile needs a toolchain w/ C++, wchar
520
#
521 522 523 524 525 526 527 528
# BR2_PACKAGE_PAX_UTILS is not set
# BR2_PACKAGE_PV is not set
# BR2_PACKAGE_RAMSMP is not set
# BR2_PACKAGE_RAMSPEED is not set
# BR2_PACKAGE_RT_TESTS is not set
# BR2_PACKAGE_SPIDEV_TEST is not set
BR2_PACKAGE_STRACE=y
# BR2_PACKAGE_STRESS is not set
529 530

#
531
# stress-ng needs a glibc toolchain w/ dynamic library, headers >= 3.3
532 533 534
#

#
535
# sysdig needs a toolchain w/ C++, gcc >= 4.7, dynamic library and a Linux kernel to be built
536
#
537 538 539 540
# BR2_PACKAGE_TINYMEMBENCH is not set
# BR2_PACKAGE_TRACE_CMD is not set
# BR2_PACKAGE_TRINITY is not set
# BR2_PACKAGE_WHETSTONE is not set
541 542

#
543
# Development tools
544
#
545 546
BR2_PACKAGE_BINUTILS=y
# BR2_PACKAGE_BINUTILS_TARGET is not set
547 548 549
# BR2_PACKAGE_BSDIFF is not set
# BR2_PACKAGE_CHECK is not set
BR2_PACKAGE_CMAKE_ARCH_SUPPORTS=y
550 551

#
552
# ctest needs a toolchain w/ C++, wchar, dynamic library, gcc >= 4.7
553 554 555
#

#
556
# cppunit needs a toolchain w/ C++, dynamic library
557
#
558
# BR2_PACKAGE_CVS is not set
559 560

#
561
# cxxtest needs a toolchain w/ C++ support
562
#
563 564 565 566 567 568 569
# BR2_PACKAGE_DIFFUTILS is not set
# BR2_PACKAGE_DOS2UNIX is not set
# BR2_PACKAGE_FINDUTILS is not set
# BR2_PACKAGE_FLEX is not set
# BR2_PACKAGE_GAWK is not set
BR2_PACKAGE_GETTEXT=y
# BR2_PACKAGE_GIT is not set
570 571

#
572
# gperf needs a toolchain w/ C++
573
#
574 575 576 577 578 579 580 581 582 583
# BR2_PACKAGE_GREP is not set
# BR2_PACKAGE_JQ is not set
# BR2_PACKAGE_LIBTOOL is not set
BR2_PACKAGE_MAKE=y
# BR2_PACKAGE_PATCH is not set
# BR2_PACKAGE_PKGCONF is not set
# BR2_PACKAGE_SED is not set
# BR2_PACKAGE_SSTRIP is not set
# BR2_PACKAGE_SUBVERSION is not set
# BR2_PACKAGE_TREE is not set
584 585

#
586
# Filesystem and flash utilities
587
#
588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604
# BR2_PACKAGE_AUTOFS is not set
# BR2_PACKAGE_BTRFS_PROGS is not set
# BR2_PACKAGE_CIFS_UTILS is not set
# BR2_PACKAGE_CPIO is not set
# BR2_PACKAGE_CRAMFS is not set
# BR2_PACKAGE_CURLFTPFS is not set
# BR2_PACKAGE_DOSFSTOOLS is not set
# BR2_PACKAGE_E2FSPROGS is not set
# BR2_PACKAGE_E2TOOLS is not set
# BR2_PACKAGE_ECRYPTFS_UTILS is not set
# BR2_PACKAGE_EXFAT is not set
# BR2_PACKAGE_EXFAT_UTILS is not set
# BR2_PACKAGE_F2FS_TOOLS is not set
# BR2_PACKAGE_FLASHBENCH is not set
# BR2_PACKAGE_GENEXT2FS is not set
# BR2_PACKAGE_GENPART is not set
# BR2_PACKAGE_GENROMFS is not set
605
# BR2_PACKAGE_MAKEDEVS is not set
606
# BR2_PACKAGE_MMC_UTILS is not set
607 608 609 610 611 612 613 614 615 616 617 618
BR2_PACKAGE_MTD=y

#
# MTD tools selection
#
# BR2_PACKAGE_MTD_DOCFDISK is not set
# BR2_PACKAGE_MTD_DOC_LOADBIOS is not set
BR2_PACKAGE_MTD_FLASHCP=y
BR2_PACKAGE_MTD_FLASH_ERASE=y
BR2_PACKAGE_MTD_FLASH_LOCK=y
# BR2_PACKAGE_MTD_FLASH_OTP_DUMP is not set
# BR2_PACKAGE_MTD_FLASH_OTP_INFO is not set
619 620
# BR2_PACKAGE_MTD_FLASH_OTP_LOCK is not set
# BR2_PACKAGE_MTD_FLASH_OTP_WRITE is not set
621 622 623 624
BR2_PACKAGE_MTD_FLASH_UNLOCK=y
# BR2_PACKAGE_MTD_FTL_CHECK is not set
# BR2_PACKAGE_MTD_FTL_FORMAT is not set
# BR2_PACKAGE_MTD_JFFS2DUMP is not set
625
# BR2_PACKAGE_MTD_MKFSJFFS2 is not set
626
# BR2_PACKAGE_MTD_MKFSUBIFS is not set
627
BR2_PACKAGE_MTD_MTD_DEBUG=y
628
# BR2_PACKAGE_MTD_MTDPART is not set
629 630 631 632 633
BR2_PACKAGE_MTD_NANDDUMP=y
BR2_PACKAGE_MTD_NANDTEST=y
BR2_PACKAGE_MTD_NANDWRITE=y
# BR2_PACKAGE_MTD_NFTLDUMP is not set
# BR2_PACKAGE_MTD_NFTL_FORMAT is not set
634
# BR2_PACKAGE_MTD_RECV_IMAGE is not set
635 636 637 638 639
# BR2_PACKAGE_MTD_RFDDUMP is not set
# BR2_PACKAGE_MTD_RFDFORMAT is not set
# BR2_PACKAGE_MTD_SERVE_IMAGE is not set
# BR2_PACKAGE_MTD_SUMTOOL is not set
BR2_PACKAGE_MTD_MTDINFO=y
640 641 642 643 644 645 646 647 648 649 650
BR2_PACKAGE_MTD_UBIATTACH=y
BR2_PACKAGE_MTD_UBICRC32=y
BR2_PACKAGE_MTD_UBIDETACH=y
BR2_PACKAGE_MTD_UBIFORMAT=y
BR2_PACKAGE_MTD_UBIMKVOL=y
BR2_PACKAGE_MTD_UBINFO=y
BR2_PACKAGE_MTD_UBINIZE=y
BR2_PACKAGE_MTD_UBIRENAME=y
BR2_PACKAGE_MTD_UBIRMVOL=y
BR2_PACKAGE_MTD_UBIRSVOL=y
BR2_PACKAGE_MTD_UBIUPDATEVOL=y
651 652 653 654
BR2_PACKAGE_MTD_UBIBLOCK=y
# BR2_PACKAGE_MTOOLS is not set
# BR2_PACKAGE_NFS_UTILS is not set
# BR2_PACKAGE_NTFS_3G is not set
655 656

#
657
# simicsfs needs a Linux kernel to be built
658
#
659 660 661 662 663 664
# BR2_PACKAGE_SP_OOPS_EXTRACT is not set
# BR2_PACKAGE_SQUASHFS is not set
# BR2_PACKAGE_SSHFS is not set
# BR2_PACKAGE_SUNXI_TOOLS is not set
# BR2_PACKAGE_UNIONFS is not set
# BR2_PACKAGE_XFSPROGS is not set
665 666

#
667
# Fonts, cursors, icons, sounds and themes
668 669 670
#

#
671
# Cursors
672
#
673 674
# BR2_PACKAGE_COMIX_CURSORS is not set
# BR2_PACKAGE_OBSIDIAN_CURSORS is not set
675 676

#
677
# Fonts
678
#
679 680 681 682 683 684
# BR2_PACKAGE_BITSTREAM_VERA is not set
# BR2_PACKAGE_CANTARELL is not set
# BR2_PACKAGE_DEJAVU is not set
# BR2_PACKAGE_GHOSTSCRIPT_FONTS is not set
# BR2_PACKAGE_INCONSOLATA is not set
# BR2_PACKAGE_LIBERATION is not set
685 686

#
687
# Icons
688
#
689 690
# BR2_PACKAGE_GOOGLE_MATERIAL_DESIGN_ICONS is not set
# BR2_PACKAGE_HICOLOR_ICON_THEME is not set
691 692

#
693
# Sounds
694
#
695 696
# BR2_PACKAGE_SOUND_THEME_BOREALIS is not set
# BR2_PACKAGE_SOUND_THEME_FREEDESKTOP is not set
697 698

#
699
# Themes
700 701 702
#

#
703
# Games
704
#
705
# BR2_PACKAGE_CHOCOLATE_DOOM is not set
706 707

#
708
# gnuchess needs a toolchain w/ C++, threads
709
#
710 711 712 713 714
# BR2_PACKAGE_LBREAKOUT2 is not set
# BR2_PACKAGE_LTRIS is not set
# BR2_PACKAGE_OPENTYRIAN is not set
# BR2_PACKAGE_PRBOOM is not set
# BR2_PACKAGE_SL is not set
715 716

#
717
# Graphic libraries and applications (graphic/text)
718 719 720
#

#
721
# Graphic applications
722
#
723 724

#
725
# expedite needs a toolchain w/ C++
726
#
727
# BR2_PACKAGE_FSWEBCAM is not set
728 729

#
730
# glmark2 needs an OpenGL or an openGL ES and EGL backend provided by mesa3d
731
#
732 733

#
734
# glmark2 needs udev /dev management and a toolchain w/ C++, NPTL
735
#
736 737 738
# BR2_PACKAGE_GNUPLOT is not set
# BR2_PACKAGE_JHEAD is not set
# BR2_PACKAGE_RRDTOOL is not set
739 740

#
741
# Graphic libraries
742 743 744
#

#
745
# cegui06 needs a toolchain w/ C++, threads, dynamic library
746 747 748
#

#
749
# directfb needs a (e)glibc or uClibc toolchain w/ C++, threads, gcc >= 4.5
750 751 752
#

#
753
# efl needs udev /dev management and a toolchain w/ C++, dynamic library, threads, wchar
754 755 756
#

#
757
# efl needs lua 5.1
758
#
759 760 761 762
# BR2_PACKAGE_FBDUMP is not set
# BR2_PACKAGE_FBGRAB is not set
# BR2_PACKAGE_FBSET is not set
# BR2_PACKAGE_FB_TEST_APP is not set
763 764

#
765
# fbterm needs a toolchain w/ C++, wchar, locale
766
#
767
# BR2_PACKAGE_FBV is not set
768 769

#
770
# freerdp needs a toolchain w/ wchar, dynamic library, threads, C++
771
#
772
# BR2_PACKAGE_IMAGEMAGICK is not set
773 774

#
775
# linux-fusion needs a Linux kernel to be built
776 777 778
#

#
779
# mesa3d needs a toolchain w/ C++, NPTL, dynamic library
780 781 782
#

#
783
# ocrad needs a toolchain w/ C++
784
#
785 786 787
# BR2_PACKAGE_PSPLASH is not set
# BR2_PACKAGE_SDL is not set
# BR2_PACKAGE_SDL2 is not set
788 789

#
790
# Other GUIs
791 792 793
#

#
794
# qt needs a toolchain w/ C++, threads
795
#
796 797 798 799 800 801 802 803 804 805
BR2_PACKAGE_QT5_JSCORE_AVAILABLE=y

#
# Qt5 needs a toolchain w/ wchar, NPTL, C++, dynamic library
#

#
# weston needs udev and a toolchain w/ locale, threads, dynamic library, headers >= 3.0
#
# BR2_PACKAGE_XORG7 is not set
806 807

#
808 809 810 811 812 813 814 815 816 817 818 819 820 821 822 823 824 825
# X applications
#

#
# midori needs libgtk2 and a toolchain w/ C++, wchar, NPTL, gcc >= 4.8
#

#
# pcmanfm needs X.org and a toolchain w/ wchar, threads, C++
#

#
# X libraries and helper libraries
#
# BR2_PACKAGE_XKEYBOARD_CONFIG is not set

#
# X window managers
826 827 828 829 830 831 832
#

#
# Hardware handling
#

#
833 834 835 836 837 838 839 840 841 842 843 844 845 846 847 848 849 850 851 852 853 854 855 856 857 858 859 860 861 862 863 864 865 866 867 868 869 870 871 872 873 874 875 876 877 878 879 880 881 882 883 884 885 886 887 888 889 890 891 892 893 894 895 896 897 898 899 900 901 902 903 904 905 906 907 908 909 910 911 912 913 914 915 916 917 918 919 920 921 922 923 924 925 926 927 928 929 930 931 932 933 934 935 936 937 938 939 940 941 942 943 944 945 946 947 948 949 950 951 952 953 954 955 956 957 958 959 960 961 962 963 964 965 966 967 968 969 970 971 972 973 974 975 976 977 978 979 980 981 982 983 984 985 986 987 988 989 990 991 992 993 994 995 996 997 998 999 1000 1001 1002 1003 1004 1005 1006 1007 1008 1009 1010 1011 1012 1013 1014 1015 1016 1017 1018 1019 1020 1021 1022 1023 1024 1025 1026 1027 1028 1029 1030 1031 1032 1033 1034 1035 1036 1037 1038 1039 1040 1041 1042 1043 1044 1045 1046 1047 1048 1049 1050 1051 1052 1053 1054 1055 1056 1057 1058 1059 1060 1061 1062 1063 1064 1065 1066 1067 1068 1069 1070 1071 1072 1073 1074 1075 1076 1077 1078 1079 1080 1081 1082 1083 1084 1085 1086 1087 1088 1089 1090 1091 1092 1093 1094 1095 1096 1097 1098 1099 1100 1101 1102 1103 1104 1105 1106 1107 1108 1109 1110 1111 1112 1113 1114 1115 1116 1117 1118 1119 1120 1121 1122 1123 1124 1125 1126 1127 1128 1129 1130 1131 1132 1133 1134 1135 1136 1137 1138 1139 1140 1141 1142 1143 1144 1145 1146 1147 1148 1149 1150 1151 1152 1153 1154 1155 1156 1157 1158 1159 1160 1161 1162 1163 1164 1165 1166 1167 1168 1169 1170 1171 1172 1173 1174 1175 1176 1177 1178 1179 1180 1181 1182 1183 1184 1185 1186 1187 1188 1189 1190 1191 1192 1193 1194 1195 1196 1197 1198 1199 1200 1201 1202 1203 1204 1205 1206 1207 1208 1209 1210 1211 1212 1213 1214 1215 1216 1217 1218 1219 1220 1221 1222 1223 1224 1225 1226 1227 1228 1229 1230 1231 1232 1233 1234 1235 1236 1237 1238 1239 1240 1241 1242 1243 1244 1245 1246 1247 1248 1249 1250 1251 1252 1253 1254 1255 1256 1257 1258 1259 1260 1261 1262 1263 1264 1265 1266 1267 1268 1269 1270 1271 1272 1273 1274 1275 1276 1277 1278 1279 1280 1281 1282 1283 1284 1285 1286 1287 1288 1289 1290 1291 1292 1293 1294 1295 1296 1297 1298 1299 1300 1301 1302 1303 1304 1305 1306 1307 1308 1309 1310 1311 1312 1313 1314 1315 1316 1317 1318 1319 1320 1321 1322 1323 1324 1325 1326 1327 1328 1329 1330 1331 1332 1333 1334 1335 1336 1337 1338 1339 1340 1341 1342 1343 1344 1345 1346 1347 1348 1349 1350 1351 1352 1353 1354 1355 1356 1357 1358 1359 1360 1361 1362 1363 1364 1365 1366 1367 1368 1369 1370 1371 1372 1373 1374 1375 1376 1377 1378 1379 1380 1381 1382 1383 1384 1385 1386 1387 1388 1389 1390 1391 1392 1393 1394 1395 1396 1397 1398 1399 1400 1401 1402 1403 1404 1405 1406 1407 1408 1409 1410 1411 1412 1413 1414 1415 1416 1417 1418 1419 1420 1421 1422 1423 1424 1425 1426 1427 1428 1429 1430 1431 1432 1433 1434 1435 1436 1437 1438 1439 1440 1441 1442 1443 1444 1445 1446 1447 1448 1449 1450 1451 1452 1453 1454 1455 1456 1457 1458 1459 1460 1461 1462 1463 1464 1465 1466 1467 1468 1469 1470 1471 1472 1473 1474 1475 1476 1477 1478 1479 1480 1481 1482 1483 1484 1485 1486 1487 1488 1489 1490 1491 1492 1493 1494 1495 1496 1497 1498 1499 1500 1501 1502 1503 1504 1505 1506 1507 1508 1509 1510 1511 1512 1513 1514 1515 1516 1517 1518 1519 1520 1521 1522 1523 1524 1525 1526 1527 1528 1529 1530 1531 1532 1533 1534 1535 1536 1537 1538 1539 1540 1541 1542 1543 1544 1545 1546 1547 1548 1549 1550 1551 1552 1553 1554 1555 1556 1557 1558 1559 1560 1561 1562 1563 1564 1565 1566 1567 1568 1569 1570 1571 1572 1573 1574 1575 1576 1577 1578 1579 1580 1581 1582 1583 1584 1585 1586 1587 1588 1589 1590 1591 1592 1593 1594 1595 1596 1597 1598 1599 1600 1601 1602 1603 1604 1605 1606 1607 1608 1609 1610 1611 1612 1613 1614 1615 1616 1617 1618 1619 1620 1621 1622 1623 1624 1625 1626 1627 1628 1629 1630 1631 1632 1633 1634 1635 1636 1637 1638 1639 1640 1641 1642 1643 1644 1645 1646 1647 1648 1649 1650 1651 1652 1653 1654 1655 1656 1657 1658 1659 1660 1661 1662 1663 1664 1665 1666 1667 1668 1669 1670 1671 1672 1673 1674 1675 1676 1677 1678 1679 1680 1681 1682 1683 1684 1685 1686 1687 1688 1689 1690 1691 1692 1693 1694 1695 1696 1697 1698 1699 1700 1701 1702 1703 1704 1705 1706 1707 1708 1709 1710 1711 1712 1713 1714 1715 1716 1717 1718 1719 1720 1721 1722 1723 1724 1725 1726 1727 1728 1729 1730 1731 1732 1733 1734 1735 1736 1737 1738 1739 1740 1741 1742 1743 1744 1745 1746 1747 1748 1749 1750 1751 1752 1753 1754 1755 1756 1757 1758 1759 1760 1761 1762 1763 1764 1765 1766 1767 1768 1769 1770 1771 1772 1773 1774 1775 1776 1777 1778 1779 1780 1781 1782 1783 1784 1785 1786 1787 1788 1789 1790 1791 1792 1793 1794 1795 1796 1797 1798 1799 1800 1801 1802 1803 1804 1805 1806 1807 1808 1809 1810 1811 1812 1813 1814 1815 1816 1817 1818 1819 1820 1821 1822 1823 1824 1825 1826 1827 1828 1829 1830 1831 1832 1833 1834 1835 1836 1837 1838 1839 1840 1841 1842 1843 1844 1845 1846 1847 1848 1849 1850 1851 1852 1853 1854 1855 1856 1857 1858 1859 1860 1861 1862 1863 1864 1865 1866 1867 1868 1869 1870 1871 1872 1873 1874 1875 1876 1877 1878 1879 1880 1881 1882 1883 1884 1885 1886 1887 1888 1889 1890 1891 1892 1893 1894 1895 1896 1897 1898 1899 1900 1901 1902 1903 1904 1905 1906 1907 1908 1909 1910 1911 1912 1913 1914 1915 1916 1917 1918 1919 1920 1921 1922 1923 1924 1925 1926 1927 1928 1929 1930 1931 1932 1933 1934 1935 1936 1937 1938 1939 1940 1941 1942 1943 1944 1945 1946 1947 1948 1949 1950 1951 1952 1953 1954 1955 1956 1957 1958 1959 1960 1961 1962 1963
# Firmware
#
# BR2_PACKAGE_AM33X_CM3 is not set
# BR2_PACKAGE_B43_FIRMWARE is not set
# BR2_PACKAGE_LINUX_FIRMWARE is not set
# BR2_PACKAGE_RPI_FIRMWARE is not set
# BR2_PACKAGE_SUNXI_BOARDS is not set
# BR2_PACKAGE_UX500_FIRMWARE is not set
# BR2_PACKAGE_ZD1211_FIRMWARE is not set

#
# a10disp needs a Linux kernel to be built
#
# BR2_PACKAGE_AM335X_PRU_PACKAGE is not set
# BR2_PACKAGE_AVRDUDE is not set

#
# bcache-tools needs udev /dev management and a toolchain w/ wchar
#

#
# cc-tool needs a toolchain w/ C++, threads, wchar
#
# BR2_PACKAGE_CDRKIT is not set
# BR2_PACKAGE_CRYPTSETUP is not set
# BR2_PACKAGE_CWIID is not set
# BR2_PACKAGE_DBUS is not set
# BR2_PACKAGE_DEVMEM2 is not set
# BR2_PACKAGE_DMRAID is not set
# BR2_PACKAGE_DTV_SCAN_TABLES is not set
# BR2_PACKAGE_DVB_APPS is not set
# BR2_PACKAGE_DVBSNOOP is not set
# BR2_PACKAGE_EDID_DECODE is not set
# BR2_PACKAGE_EEPROG is not set

#
# eudev needs eudev /dev management
#
# BR2_PACKAGE_EVEMU is not set
# BR2_PACKAGE_EVTEST is not set
# BR2_PACKAGE_FAN_CTRL is not set
# BR2_PACKAGE_FCONFIG is not set
# BR2_PACKAGE_FIS is not set
# BR2_PACKAGE_FMTOOLS is not set
# BR2_PACKAGE_FREESCALE_IMX is not set
# BR2_PACKAGE_FXLOAD is not set
# BR2_PACKAGE_GADGETFS_TEST is not set
# BR2_PACKAGE_GPM is not set
# BR2_PACKAGE_GPSD is not set

#
# gptfdisk needs a toolchain w/ wchar, C++
#
# BR2_PACKAGE_GVFS is not set
# BR2_PACKAGE_HDPARM is not set
# BR2_PACKAGE_HWDATA is not set
# BR2_PACKAGE_HWLOC is not set
# BR2_PACKAGE_I2C_TOOLS is not set
# BR2_PACKAGE_INPUT_EVENT_DAEMON is not set
# BR2_PACKAGE_INPUT_TOOLS is not set
# BR2_PACKAGE_IOSTAT is not set
# BR2_PACKAGE_IPMITOOL is not set

#
# iqvlinux needs a Linux kernel to be built
#
# BR2_PACKAGE_IRDA_UTILS is not set
# BR2_PACKAGE_KBD is not set
# BR2_PACKAGE_LCDPROC is not set

#
# libump needs a (e)glibc toolchain
#

#
# linux-backports needs a Linux kernel to be built
#
# BR2_PACKAGE_LIRC_TOOLS is not set
# BR2_PACKAGE_LM_SENSORS is not set

#
# lshw needs a toolchain w/ C++, wchar
#
# BR2_PACKAGE_LSUIO is not set
# BR2_PACKAGE_LVM2 is not set
# BR2_PACKAGE_MDADM is not set
# BR2_PACKAGE_MEMTESTER is not set
# BR2_PACKAGE_MINICOM is not set
# BR2_PACKAGE_NANOCOM is not set
# BR2_PACKAGE_NEARD is not set
# BR2_PACKAGE_OFONO is not set

#
# ola needs a toolchain w/ C++, threads, wchar, dynamic library
#

#
# on2-8170-modules needs a Linux kernel to be built
#
# BR2_PACKAGE_OPEN2300 is not set
# BR2_PACKAGE_OPENIPMI is not set
# BR2_PACKAGE_OPENOCD is not set

#
# owl-linux needs a Linux kernel to be built
#
# BR2_PACKAGE_PARTED is not set
# BR2_PACKAGE_PCIUTILS is not set
# BR2_PACKAGE_PICOCOM is not set
# BR2_PACKAGE_PIFMRDS is not set

#
# powertop needs a toolchain w/ C++, threads, wchar
#
# BR2_PACKAGE_PPS_TOOLS is not set
# BR2_PACKAGE_READ_EDID is not set
# BR2_PACKAGE_RFKILL is not set
# BR2_PACKAGE_RNG_TOOLS is not set

#
# rpi-userland needs a toolchain w/ C++, threads, dynamic library
#

#
# rtl8188eu needs a Linux kernel to be built
#

#
# rtl8821au needs a Linux kernel to be built
#
# BR2_PACKAGE_SANE_BACKENDS is not set
# BR2_PACKAGE_SDPARM is not set
# BR2_PACKAGE_SETSERIAL is not set
# BR2_PACKAGE_SG3_UTILS is not set
# BR2_PACKAGE_SIGROK_CLI is not set
# BR2_PACKAGE_SISPMCTL is not set

#
# smartmontools needs a toolchain w/ C++
#
# BR2_PACKAGE_SMSTOOLS3 is not set
# BR2_PACKAGE_SNOWBALL_HDMISERVICE is not set
# BR2_PACKAGE_SPI_TOOLS is not set
# BR2_PACKAGE_SREDIRD is not set
# BR2_PACKAGE_STATSERIAL is not set
# BR2_PACKAGE_STM32FLASH is not set

#
# sunxi-cedarx needs an (e)glibc toolchain
#

#
# sunxi-mali needs an (e)glibc toolchain
#
# BR2_PACKAGE_SYSSTAT is not set

#
# targetcli-fb depends on Python
#

#
# ti-gfx needs an (e)glibc toolchain and a Linux kernel to be built
#
# BR2_PACKAGE_TI_UIM is not set
# BR2_PACKAGE_TI_UTILS is not set
# BR2_PACKAGE_TRIGGERHAPPY is not set
# BR2_PACKAGE_UBOOT_TOOLS is not set
# BR2_PACKAGE_UBUS is not set

#
# udisks needs udev /dev management
#
# BR2_PACKAGE_USB_MODESWITCH is not set
# BR2_PACKAGE_USB_MODESWITCH_DATA is not set

#
# usbmount requires udev to be enabled
#

#
# usbutils needs udev /dev management and toolchain w/ threads
#
# BR2_PACKAGE_W_SCAN is not set
# BR2_PACKAGE_WIPE is not set
# BR2_PACKAGE_XORRISO is not set

#
# Interpreter languages and scripting
#
# BR2_PACKAGE_ENSCRIPT is not set
# BR2_PACKAGE_ERLANG is not set
BR2_PACKAGE_GAUCHE_ARCH_SUPPORTS=y
# BR2_PACKAGE_GAUCHE is not set
# BR2_PACKAGE_GUILE is not set
# BR2_PACKAGE_HASERL is not set
# BR2_PACKAGE_JAMVM is not set
# BR2_PACKAGE_JIMTCL is not set
# BR2_PACKAGE_LUA is not set
BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS=y
# BR2_PACKAGE_LUAJIT is not set
# BR2_PACKAGE_MICROPYTHON is not set
# BR2_PACKAGE_MOARVM is not set
BR2_PACKAGE_MONO_ARCH_SUPPORTS=y
# BR2_PACKAGE_MONO is not set

#
# nodejs needs a toolchain w/ C++, dynamic library, threads, gcc >= 4.8, wchar
#
# BR2_PACKAGE_PERL is not set
BR2_PACKAGE_PHP=y

#
# Extensions
#
# BR2_PACKAGE_PHP_EXT_CALENDAR is not set
# BR2_PACKAGE_PHP_EXT_FILEINFO is not set
# BR2_PACKAGE_PHP_EXT_OPCACHE is not set
# BR2_PACKAGE_PHP_EXT_READLINE is not set
BR2_PACKAGE_PHP_EXT_SESSION=y

#
# Compression extensions
#
# BR2_PACKAGE_PHP_EXT_BZIP2 is not set
# BR2_PACKAGE_PHP_EXT_PHAR is not set
# BR2_PACKAGE_PHP_EXT_ZIP is not set
BR2_PACKAGE_PHP_EXT_ZLIB=y

#
# Cryptography extensions
#
# BR2_PACKAGE_PHP_EXT_HASH is not set
# BR2_PACKAGE_PHP_EXT_MCRYPT is not set
# BR2_PACKAGE_PHP_EXT_OPENSSL is not set

#
# Database extensions
#
# BR2_PACKAGE_PHP_EXT_DBA is not set
# BR2_PACKAGE_PHP_EXT_SQLITE is not set
# BR2_PACKAGE_PHP_EXT_PDO is not set

#
# Human language and character encoding support
#
# BR2_PACKAGE_PHP_EXT_GETTEXT is not set
# BR2_PACKAGE_PHP_EXT_ICONV is not set

#
# intl support needs a toolchain w/ C++, wchar, threads
#
# BR2_PACKAGE_PHP_EXT_MBSTRING is not set

#
# Image processing
#
# BR2_PACKAGE_PHP_EXT_EXIF is not set
# BR2_PACKAGE_PHP_EXT_GD is not set

#
# Mathematical extensions
#
# BR2_PACKAGE_PHP_EXT_BCMATH is not set
# BR2_PACKAGE_PHP_EXT_GMP is not set

#
# Other basic extensions
#
# BR2_PACKAGE_PHP_EXT_JSON is not set
# BR2_PACKAGE_PHP_EXT_TOKENIZER is not set

#
# Other services
#
# BR2_PACKAGE_PHP_EXT_CURL is not set
# BR2_PACKAGE_PHP_EXT_FTP is not set
# BR2_PACKAGE_PHP_EXT_SNMP is not set
# BR2_PACKAGE_PHP_EXT_SOCKETS is not set

#
# Process Control
#
# BR2_PACKAGE_PHP_EXT_PCNTL is not set
BR2_PACKAGE_PHP_EXT_POSIX=y
# BR2_PACKAGE_PHP_EXT_SHMOP is not set
# BR2_PACKAGE_PHP_EXT_SYSVMSG is not set
# BR2_PACKAGE_PHP_EXT_SYSVSEM is not set
# BR2_PACKAGE_PHP_EXT_SYSVSHM is not set

#
# Variable and Type related
#
# BR2_PACKAGE_PHP_EXT_CTYPE is not set
# BR2_PACKAGE_PHP_EXT_FILTER is not set

#
# Web services
#
# BR2_PACKAGE_PHP_EXT_SOAP is not set
# BR2_PACKAGE_PHP_EXT_XMLRPC is not set

#
# XML manipulation
#
# BR2_PACKAGE_PHP_EXT_DOM is not set
# BR2_PACKAGE_PHP_EXT_LIBXML2 is not set
# BR2_PACKAGE_PHP_EXT_SIMPLEXML is not set
# BR2_PACKAGE_PHP_EXT_WDDX is not set
# BR2_PACKAGE_PHP_EXT_XML is not set
# BR2_PACKAGE_PHP_EXT_XMLREADER is not set
# BR2_PACKAGE_PHP_EXT_XMLWRITER is not set
# BR2_PACKAGE_PHP_EXT_XSL is not set
BR2_PACKAGE_PHP_CLI=y
BR2_PACKAGE_PHP_CGI=y
# BR2_PACKAGE_PHP_SAPI_CGI is not set
# BR2_PACKAGE_PHP_SAPI_CLI is not set
# BR2_PACKAGE_PHP_SAPI_FPM is not set
BR2_PACKAGE_PHP_SAPI_CLI_CGI=y
# BR2_PACKAGE_PHP_SAPI_CLI_FPM is not set

#
# External php extensions
#
# BR2_PACKAGE_PHP_GEOIP is not set
# BR2_PACKAGE_PHP_GNUPG is not set
# BR2_PACKAGE_PHP_IMAGICK is not set

#
# php-memcached needs a toolchain w/ C++, threads
#
# BR2_PACKAGE_PHP_SSH2 is not set
# BR2_PACKAGE_PHP_YAML is not set

#
# php-zmq needs a toolchain w/ C++, wchar, threads
#
# BR2_PACKAGE_PYTHON is not set
# BR2_PACKAGE_PYTHON3 is not set
# BR2_PACKAGE_RUBY is not set
# BR2_PACKAGE_TCL is not set

#
# Libraries
#

#
# Audio/Sound
#
# BR2_PACKAGE_ALSA_LIB is not set

#
# audiofile needs a toolchain w/ C++
#
# BR2_PACKAGE_CELT051 is not set

#
# fdk-aac needs a toolchain w/ C++
#
# BR2_PACKAGE_LIBAO is not set
# BR2_PACKAGE_LIBBROADVOICE is not set
# BR2_PACKAGE_LIBCDAUDIO is not set
# BR2_PACKAGE_LIBCDDB is not set
# BR2_PACKAGE_LIBCDIO is not set
# BR2_PACKAGE_LIBCODEC2 is not set
# BR2_PACKAGE_LIBCUE is not set
# BR2_PACKAGE_LIBCUEFILE is not set
# BR2_PACKAGE_LIBG7221 is not set
# BR2_PACKAGE_LIBID3TAG is not set
# BR2_PACKAGE_LIBILBC is not set
# BR2_PACKAGE_LIBLO is not set
# BR2_PACKAGE_LIBMAD is not set

#
# libmodplug needs a toolchain w/ C++
#
# BR2_PACKAGE_LIBMPD is not set
# BR2_PACKAGE_LIBMPDCLIENT is not set
# BR2_PACKAGE_LIBREPLAYGAIN is not set
# BR2_PACKAGE_LIBSAMPLERATE is not set

#
# libsidplay2 needs a toolchain w/ C++
#
# BR2_PACKAGE_LIBSILK is not set
# BR2_PACKAGE_LIBSNDFILE is not set

#
# libsoundtouch needs a toolchain w/ C++
#
# BR2_PACKAGE_LIBSOXR is not set
# BR2_PACKAGE_LIBVORBIS is not set

#
# mp4v2 needs a toolchain w/ C++
#
BR2_PACKAGE_OPENAL_ARCH_SUPPORTS=y

#
# openal needs a toolchain w/ NPTL, C++
#

#
# opencore-amr needs a toolchain w/ C++
#
# BR2_PACKAGE_OPUS is not set
# BR2_PACKAGE_OPUSFILE is not set
# BR2_PACKAGE_PORTAUDIO is not set
# BR2_PACKAGE_SBC is not set
# BR2_PACKAGE_SPEEX is not set

#
# taglib needs a toolchain w/ C++, wchar
#
# BR2_PACKAGE_TINYALSA is not set
# BR2_PACKAGE_TREMOR is not set
# BR2_PACKAGE_VO_AACENC is not set

#
# webrtc-audio-processing needs a toolchain w/ C++, threads
#

#
# Compression and decompression
#
# BR2_PACKAGE_LIBARCHIVE is not set

#
# libsquish needs a toolchain w/ C++, dynamic library
#
# BR2_PACKAGE_LIBZIP is not set
BR2_PACKAGE_LZO=y
# BR2_PACKAGE_MINIZIP is not set

#
# snappy needs a toolchain w/ C++
#
# BR2_PACKAGE_SZIP is not set
BR2_PACKAGE_ZLIB=y

#
# Crypto
#
# BR2_PACKAGE_BEECRYPT is not set
BR2_PACKAGE_BOTAN_ARCH_SUPPORTS=y

#
# botan needs a toolchain w/ C++, threads
#
# BR2_PACKAGE_CA_CERTIFICATES is not set

#
# cryptodev needs a Linux kernel to be built
#
# BR2_PACKAGE_GCR is not set
# BR2_PACKAGE_GNUTLS is not set
# BR2_PACKAGE_LIBASSUAN is not set
# BR2_PACKAGE_LIBGCRYPT is not set
# BR2_PACKAGE_LIBGPG_ERROR is not set
# BR2_PACKAGE_LIBGPGME is not set
# BR2_PACKAGE_LIBKSBA is not set
# BR2_PACKAGE_LIBMCRYPT is not set
# BR2_PACKAGE_LIBMHASH is not set
# BR2_PACKAGE_LIBNSS is not set
# BR2_PACKAGE_LIBSECRET is not set
# BR2_PACKAGE_LIBSHA1 is not set
# BR2_PACKAGE_LIBSODIUM is not set
# BR2_PACKAGE_LIBSSH is not set
# BR2_PACKAGE_LIBSSH2 is not set
# BR2_PACKAGE_LIBUECC is not set
# BR2_PACKAGE_MBEDTLS is not set
# BR2_PACKAGE_NETTLE is not set
BR2_PACKAGE_OPENSSL=y
# BR2_PACKAGE_OPENSSL_BIN is not set
# BR2_PACKAGE_OPENSSL_ENGINES is not set
# BR2_PACKAGE_POLARSSL is not set
# BR2_PACKAGE_TROUSERS is not set

#
# Database
#
# BR2_PACKAGE_BERKELEYDB is not set
# BR2_PACKAGE_GDBM is not set

#
# kompexsqlite needs a toolchain w/ C++, wchar, threads, dynamic library
#

#
# leveldb needs a toolchain w/ C++, threads
#

#
# MySQL needs a toolchain w/ C++, threads
#
# BR2_PACKAGE_POSTGRESQL is not set
# BR2_PACKAGE_REDIS is not set
# BR2_PACKAGE_SQLCIPHER is not set
# BR2_PACKAGE_SQLITE is not set
# BR2_PACKAGE_UNIXODBC is not set

#
# Filesystem
#
# BR2_PACKAGE_GAMIN is not set
# BR2_PACKAGE_LIBCONFIG is not set
# BR2_PACKAGE_LIBCONFUSE is not set
# BR2_PACKAGE_LIBFUSE is not set
# BR2_PACKAGE_LIBLOCKFILE is not set
# BR2_PACKAGE_LIBNFS is not set
# BR2_PACKAGE_LIBSYSFS is not set
# BR2_PACKAGE_LOCKDEV is not set

#
# Graphics
#

#
# assimp needs a toolchain w/ C++
#
# BR2_PACKAGE_ATK is not set

#
# atkmm needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
#

#
# bullet needs a toolchain w/ C++
#
# BR2_PACKAGE_CAIRO is not set

#
# cairomm needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
#

#
# exiv2 needs a toolchain w/ C++, wchar, dynamic library
#
# BR2_PACKAGE_FONTCONFIG is not set
# BR2_PACKAGE_FREETYPE is not set
# BR2_PACKAGE_GD is not set
# BR2_PACKAGE_GDK_PIXBUF is not set
# BR2_PACKAGE_GIFLIB is not set

#
# graphite2 needs a toolchain w/ C++, dynamic library
#

#
# gtkmm3 needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
#

#
# harfbuzz needs a toolchain w/ C++
#
# BR2_PACKAGE_IJS is not set
# BR2_PACKAGE_IMLIB2 is not set
# BR2_PACKAGE_JASPER is not set
# BR2_PACKAGE_JPEG is not set
# BR2_PACKAGE_LCMS2 is not set
# BR2_PACKAGE_LIBART is not set
# BR2_PACKAGE_LIBDMTX is not set
# BR2_PACKAGE_LIBDRM is not set
# BR2_PACKAGE_LIBEXIF is not set

#
# libfm needs X.org and a toolchain w/ wchar, threads, C++
#
# BR2_PACKAGE_LIBFM_EXTRA is not set

#
# libfreeglut depends on X.org and needs an OpenGL backend
#

#
# libfreeimage needs a toolchain w/ C++, dynamic library, wchar
#
# BR2_PACKAGE_LIBGEOTIFF is not set

#
# libglew depends on X.org and needs an OpenGL backend
#

#
# libglfw depends on X.org and needs an OpenGL backend
#

#
# libglu needs an OpenGL backend
#

#
# libgtk3 needs a toolchain w/ wchar, threads, C++
#
# BR2_PACKAGE_LIBMNG is not set
# BR2_PACKAGE_LIBPNG is not set
# BR2_PACKAGE_LIBQRENCODE is not set

#
# libraw needs a toolchain w/ C++
#

#
# librsvg needs a toolchain w/ wchar, threads, C++
#

#
# libsoil needs an OpenGL backend and a toolchain w/ dynamic library
#
# BR2_PACKAGE_LIBSVG is not set
# BR2_PACKAGE_LIBSVG_CAIRO is not set
# BR2_PACKAGE_LIBSVGTINY is not set
# BR2_PACKAGE_LIBVA is not set

#
# libvips needs a toolchain w/ wchar, threads, C++
#
# BR2_PACKAGE_MENU_CACHE is not set

#
# opencv needs a toolchain w/ C++, NPTL, wchar
#

#
# opencv3 needs a toolchain w/ C++, NPTL, wchar, dynamic library
#
# BR2_PACKAGE_OPENJPEG is not set

#
# pango needs a toolchain w/ wchar, threads, C++
#

#
# pangomm needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
#
# BR2_PACKAGE_PIXMAN is not set

#
# poppler needs a toolchain w/ C++, threads
#
# BR2_PACKAGE_TIFF is not set
# BR2_PACKAGE_WAYLAND is not set
BR2_PACKAGE_WEBKITGTK24_ARCH_SUPPORTS=y

#
# webkitgtk24 needs libgtk2 and a toolchain w/ C++, wchar, NPTL, gcc >=4.8
#
# BR2_PACKAGE_WEBP is not set

#
# zbar needs a toolchain w/ threads, dynamic library, C++ and headers >= 3.0
#

#
# zxing-cpp needs a toolchain w/ C++, dynamic library
#

#
# Hardware handling
#
# BR2_PACKAGE_ACSCCID is not set
# BR2_PACKAGE_BCM2835 is not set
# BR2_PACKAGE_C_PERIPHERY is not set
# BR2_PACKAGE_CCID is not set
# BR2_PACKAGE_DTC is not set

#
# hidapi needs udev /dev management and a toolchain w/ threads
#

#
# lcdapi needs a toolchain w/ C++, threads
#
BR2_PACKAGE_LIBAIO_ARCH_SUPPORTS=y
# BR2_PACKAGE_LIBAIO is not set

#
# libatasmart requires udev to be enabled
#

#
# libcec needs a toolchain w/ C++, wchar, threads, dynamic library, gcc >= 4.7
#
# BR2_PACKAGE_LIBFREEFARE is not set
# BR2_PACKAGE_LIBFTDI is not set
# BR2_PACKAGE_LIBFTDI1 is not set

#
# libgudev needs udev /dev handling and a toolchain w/ wchar, threads
#
# BR2_PACKAGE_LIBHID is not set
# BR2_PACKAGE_LIBIIO is not set

#
# libinput needs udev /dev management and a toolchain w/ locale
#
# BR2_PACKAGE_LIBIQRF is not set
# BR2_PACKAGE_LIBLLCP is not set

#
# libmbim needs udev /dev management and a toolchain w/ wchar, threads
#
# BR2_PACKAGE_LIBNFC is not set
# BR2_PACKAGE_LIBPCIACCESS is not set
# BR2_PACKAGE_LIBPHIDGET is not set
# BR2_PACKAGE_LIBQMI is not set
# BR2_PACKAGE_LIBRAW1394 is not set
# BR2_PACKAGE_LIBRTLSDR is not set

#
# libserial needs a toolchain w/ C++, threads, wchar
#
# BR2_PACKAGE_LIBSERIALPORT is not set
# BR2_PACKAGE_LIBSIGROK is not set
# BR2_PACKAGE_LIBSIGROKDECODE is not set
# BR2_PACKAGE_LIBSOC is not set
# BR2_PACKAGE_LIBUSB is not set

#
# libv4l needs a toolchain w/ threads, dynamic library, C++ and headers >= 3.0
#
# BR2_PACKAGE_LIBXKBCOMMON is not set
# BR2_PACKAGE_MRAA is not set
# BR2_PACKAGE_MTDEV is not set

#
# ne10 needs a toolchain w/ neon
#
# BR2_PACKAGE_NEARDAL is not set
# BR2_PACKAGE_PCSC_LITE is not set
# BR2_PACKAGE_TSLIB is not set

#
# urg needs a toolchain w/ C++
#

#
# Javascript
#
# BR2_PACKAGE_ANGULARJS is not set
# BR2_PACKAGE_BOOTSTRAP is not set
# BR2_PACKAGE_EXPLORERCANVAS is not set
# BR2_PACKAGE_FLOT is not set
# BR2_PACKAGE_JQUERY is not set
# BR2_PACKAGE_JSMIN is not set
# BR2_PACKAGE_JSON_JAVASCRIPT is not set

#
# JSON/XML
#

#
# benejson needs a toolchain w/ C++
#
# BR2_PACKAGE_CJSON is not set
# BR2_PACKAGE_EXPAT is not set
# BR2_PACKAGE_EZXML is not set
# BR2_PACKAGE_JANSSON is not set
BR2_PACKAGE_JSON_C=y
# BR2_PACKAGE_JSON_GLIB is not set

#
# jsoncpp needs a toolchain w/ C++, gcc >= 4.7
#

#
# libjson needs a toolchain w/ C++
#
# BR2_PACKAGE_LIBROXML is not set
# BR2_PACKAGE_LIBUCL is not set
# BR2_PACKAGE_LIBXML2 is not set

#
# libxml++ needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
#
# BR2_PACKAGE_LIBXMLRPC is not set
# BR2_PACKAGE_LIBXSLT is not set
# BR2_PACKAGE_LIBYAML is not set
# BR2_PACKAGE_MXML is not set
# BR2_PACKAGE_RAPIDJSON is not set
# BR2_PACKAGE_RAPIDXML is not set

#
# tinyxml needs a toolchain w/ C++
#

#
# tinyxml2 needs a toolchain w/ C++
#

#
# xerces-c++ needs a toolchain w/ C++, wchar
#
# BR2_PACKAGE_YAJL is not set

#
# yaml-cpp needs a toolchain w/ C++, threads, wchar
#

#
# Logging
#
# BR2_PACKAGE_EVENTLOG is not set

#
# glog needs a toolchain w/ C++, threads, dynamic library
#
# BR2_PACKAGE_LIBLOG4C_LOCALTIME is not set
BR2_PACKAGE_LIBLOGGING=y

#
# log4cplus needs a toolchain w/ C++, wchar, threads
#

#
# log4cxx needs a toolchain w/ C++, threads, dynamic library
#
# BR2_PACKAGE_ZLOG is not set

#
# Multimedia
#
# BR2_PACKAGE_BITSTREAM is not set
# BR2_PACKAGE_LIBASS is not set
# BR2_PACKAGE_LIBBLURAY is not set
# BR2_PACKAGE_LIBDCADEC is not set
# BR2_PACKAGE_LIBDVBCSA is not set
# BR2_PACKAGE_LIBDVBPSI is not set

#
# libdvbsi++ needs a toolchain w/ C++, wchar, threads
#
# BR2_PACKAGE_LIBDVDNAV is not set
# BR2_PACKAGE_LIBDVDREAD is not set

#
# libebml needs a toolchain w/ C++, wchar
#

#
# libfslcodec needs an (e)glibc toolchain
#
# BR2_PACKAGE_LIBFSLPARSER is not set

#
# libfslvpuwrap needs an imx-specific Linux kernel to be built
#
# BR2_PACKAGE_LIBHDHOMERUN is not set

#
# libmatroska needs a toolchain w/ C++, wchar
#
# BR2_PACKAGE_LIBMMS is not set
# BR2_PACKAGE_LIBMPEG2 is not set
# BR2_PACKAGE_LIBOGG is not set
BR2_PACKAGE_LIBOPENH264_ARCH_SUPPORTS=y

#
# libopenh264 needs a toolchain w/ C++, dynamic library, threads
#
# BR2_PACKAGE_LIBPLAYER is not set
# BR2_PACKAGE_LIBTHEORA is not set
# BR2_PACKAGE_LIBVPX is not set

#
# libyuv needs a toolchain w/ C++, dynamic library
#

#
# live555 needs a toolchain w/ C++
#

#
# mediastreamer needs a toolchain w/ threads, C++
#
# BR2_PACKAGE_X264 is not set

#
# x265 needs a toolchain w/ C++, threads, dynamic library
#

#
# Networking
#

#
# agent++ needs a toolchain w/ threads, C++, dynamic library
#
# BR2_PACKAGE_C_ARES is not set
BR2_PACKAGE_CANFESTIVAL_ARCH_SUPPORTS=y
# BR2_PACKAGE_CANFESTIVAL is not set
# BR2_PACKAGE_CGIC is not set

#
# cppzmq needs a toolchain w/ C++, wchar, threads
#

#
# czmq needs a toolchain w/ C++, wchar, threads
#

#
# filemq needs a toolchain w/ C++, wchar, threads
#
# BR2_PACKAGE_FLICKCURL is not set
# BR2_PACKAGE_FREERADIUS_CLIENT is not set
# BR2_PACKAGE_GEOIP is not set
# BR2_PACKAGE_GLIB_NETWORKING is not set
# BR2_PACKAGE_GSSDP is not set
# BR2_PACKAGE_GUPNP is not set
# BR2_PACKAGE_GUPNP_AV is not set

#
# ibrcommon needs a toolchain w/ C++, threads
#

#
# ibrdtn needs a toolchain w/ C++, threads
#
# BR2_PACKAGE_LIBCGI is not set

#
# libcgicc needs a toolchain w/ C++
#
# BR2_PACKAGE_LIBCURL is not set
# BR2_PACKAGE_LIBDNET is not set
# BR2_PACKAGE_LIBEXOSIP2 is not set
# BR2_PACKAGE_LIBFCGI is not set
# BR2_PACKAGE_LIBGSASL is not set
# BR2_PACKAGE_LIBHTTPPARSER is not set
# BR2_PACKAGE_LIBIDN is not set
# BR2_PACKAGE_LIBISCSI is not set
# BR2_PACKAGE_LIBLDNS is not set
# BR2_PACKAGE_LIBMBUS is not set

#
# libmemcached needs a toolchain w/ C++, threads
#
# BR2_PACKAGE_LIBMICROHTTPD is not set
# BR2_PACKAGE_LIBMNL is not set
# BR2_PACKAGE_LIBMODBUS is not set
# BR2_PACKAGE_LIBNDP is not set
# BR2_PACKAGE_LIBNET is not set
# BR2_PACKAGE_LIBNETFILTER_ACCT is not set
# BR2_PACKAGE_LIBNETFILTER_CONNTRACK is not set
# BR2_PACKAGE_LIBNETFILTER_CTHELPER is not set
# BR2_PACKAGE_LIBNETFILTER_CTTIMEOUT is not set
# BR2_PACKAGE_LIBNETFILTER_LOG is not set
# BR2_PACKAGE_LIBNETFILTER_QUEUE is not set
# BR2_PACKAGE_LIBNFNETLINK is not set
# BR2_PACKAGE_LIBNFTNL is not set
# BR2_PACKAGE_LIBNICE is not set
# BR2_PACKAGE_LIBNL is not set
# BR2_PACKAGE_LIBOAUTH is not set
# BR2_PACKAGE_LIBOPING is not set
# BR2_PACKAGE_LIBOSIP2 is not set
BR2_PACKAGE_LIBPCAP=y
# BR2_PACKAGE_LIBRSYNC is not set
# BR2_PACKAGE_LIBSHAIRPLAY is not set
# BR2_PACKAGE_LIBSHOUT is not set
# BR2_PACKAGE_LIBSOCKETCAN is not set
# BR2_PACKAGE_LIBSOUP is not set
# BR2_PACKAGE_LIBSRTP is not set
# BR2_PACKAGE_LIBSTROPHE is not set
# BR2_PACKAGE_LIBTIRPC is not set

#
# libtorrent needs a toolchain w/ C++, threads
#
# BR2_PACKAGE_LIBUPNP is not set

#
# libupnpp needs a toolchain w/ C++, threads, gcc >= 4.6
#
# BR2_PACKAGE_LIBURIPARSER is not set
# BR2_PACKAGE_LIBVNCSERVER is not set
# BR2_PACKAGE_LIBWEBSOCK is not set
# BR2_PACKAGE_LIBWEBSOCKETS is not set
# BR2_PACKAGE_MONGOOSE is not set
# BR2_PACKAGE_NEON is not set

#
# nss-pam-ldapd needs an (e)glibc toolchain
#

#
# omniORB needs a toolchain w/ C++, threads
#
# BR2_PACKAGE_OPENLDAP is not set
# BR2_PACKAGE_OPENPGM is not set
# BR2_PACKAGE_ORTP is not set
# BR2_PACKAGE_QDECODER is not set
# BR2_PACKAGE_QPID_PROTON is not set
# BR2_PACKAGE_RABBITMQ_C is not set
# BR2_PACKAGE_RTMPDUMP is not set
# BR2_PACKAGE_SLIRP is not set

#
# snmp++ needs a toolchain w/ threads, C++, dynamic library
#
# BR2_PACKAGE_SOFIA_SIP is not set

#
# thrift needs a toolchain w/ C++, wchar, threads
#
# BR2_PACKAGE_USBREDIR is not set

#
# wvstreams needs a (e)glibc or uClibc toolchain w/ C++, dynamic library
#

#
# zeromq needs a toolchain w/ C++, wchar, threads
#

#
# zmqpp needs a toolchain w/ C++, wchar, threads, gcc >= 4.6
#

#
# zyre needs a toolchain w/ C++, wchar, threads
#

#
# Other
#
# BR2_PACKAGE_APR is not set
# BR2_PACKAGE_APR_UTIL is not set
BR2_PACKAGE_ARGP_STANDALONE=y

#
# armadillo needs a toolchain w/ C++
#

#
# atf needs a toolchain w/ C++
#
# BR2_PACKAGE_BDWGC is not set

#
# boost needs a toolchain w/ C++, threads, wchar
#
BR2_PACKAGE_BOOST_ARCH_SUPPORTS=y
# BR2_PACKAGE_CLAPACK is not set

#
# cppcms needs a toolchain w/ C++, NPTL, wchar, dynamic library
#

#
# dawgdic needs a toolchain w/ C++, gcc >= 4.6
#
# BR2_PACKAGE_DING_LIBS is not set

#
# eigen needs a toolchain w/ C++
#
BR2_PACKAGE_ELFUTILS=y
# BR2_PACKAGE_FFTW is not set

#
# flann needs a toolchain w/ C++, dynamic library
#

#
# gflags needs a toolchain w/ C++
#

#
# glibmm needs a toolchain w/ C++, wchar, threads, gcc >= 4.8
#

#
# glm needs a toolchain w/ C++
#

#
# gmock needs a toolchain w/ C++, wchar, threads
#
# BR2_PACKAGE_GMP is not set
# BR2_PACKAGE_GSL is not set

#
# gtest needs a toolchain w/ C++, wchar, threads
#
# BR2_PACKAGE_LIBARGTABLE2 is not set
BR2_PACKAGE_LIBATOMIC_OPS_ARCH_SUPPORTS=y
# BR2_PACKAGE_LIBATOMIC_OPS is not set
BR2_PACKAGE_LIBBSD_ARCH_SUPPORTS=y

#
# libbsd needs an (e)glibc toolchain w/ threads
#
# BR2_PACKAGE_LIBCAP is not set
# BR2_PACKAGE_LIBCAP_NG is not set

#
# libcgroup needs an (e)glibc toolchain w/ C++
#
# BR2_PACKAGE_LIBCOFI is not set
# BR2_PACKAGE_LIBCROCO is not set

#
# libcrossguid needs a toolchain w/ C++, wchar, gcc >= 4.7
#
BR2_PACKAGE_LIBDAEMON=y
# BR2_PACKAGE_LIBEE is not set
# BR2_PACKAGE_LIBEV is not set
# BR2_PACKAGE_LIBEVDEV is not set
# BR2_PACKAGE_LIBEVENT is not set
BR2_PACKAGE_LIBFFI=y
# BR2_PACKAGE_LIBGLIB2 is not set

#
# libical needs a toolchain w/ C++, dynamic library, wchar
#

#
# liblinear needs a toolchain w/ C++
#
BR2_PACKAGE_LIBNSPR_ARCH_SUPPORT=y
# BR2_PACKAGE_LIBNSPR is not set
# BR2_PACKAGE_LIBPFM4 is not set

#
# libplist needs a toolchain w/ C++
#
# BR2_PACKAGE_LIBPTHREAD_STUBS is not set
# BR2_PACKAGE_LIBPTHSEM is not set

#
# libsigc++ needs a toolchain w/ C++, gcc >= 4.7
1964
#
1965 1966 1967 1968 1969 1970 1971 1972 1973 1974 1975
# BR2_PACKAGE_LIBSIGSEGV is not set
# BR2_PACKAGE_LIBTASN1 is not set
# BR2_PACKAGE_LIBTPL is not set
# BR2_PACKAGE_LIBUBOX is not set
# BR2_PACKAGE_LIBUCI is not set
BR2_PACKAGE_LIBUNWIND_ARCH_SUPPORTS=y
# BR2_PACKAGE_LIBUNWIND is not set
BR2_PACKAGE_LIBURCU_ARCH_SUPPORTS=y
# BR2_PACKAGE_LIBURCU is not set
# BR2_PACKAGE_LIBUV is not set
# BR2_PACKAGE_LIGHTNING is not set
1976 1977

#
1978
# linux-pam needs a uClibc or (e)glibc toolchain w/ wchar, locale, dynamic library
1979 1980 1981
#

#
1982
# liquid-dsp requires a (e)glibc/musl toolchain w/ dynamic library
1983
#
1984 1985 1986 1987
# BR2_PACKAGE_LTTNG_LIBUST is not set
# BR2_PACKAGE_MPC is not set
# BR2_PACKAGE_MPDECIMAL is not set
# BR2_PACKAGE_MPFR is not set
1988 1989

#
1990
# msgpack needs a toolchain w/ C++
1991
#
1992 1993 1994
# BR2_PACKAGE_MTDEV2TUIO is not set
# BR2_PACKAGE_ORC is not set
# BR2_PACKAGE_P11_KIT is not set
1995 1996

#
1997
# poco needs a toolchain w/ wchar, threads, C++, dynamic library
1998
#
1999
BR2_PACKAGE_PROTOBUF_ARCH_SUPPORTS=y
2000 2001

#
2002
# protobuf needs a toolchain w/ C++, threads, dynamic library
2003 2004 2005
#

#
2006
# protobuf-c needs a toolchain w/ C++, threads
2007 2008 2009
#

#
2010
# qhull needs a toolchain w/ C++, dynamic library, gcc >= 4.4
2011
#
2012 2013 2014 2015 2016 2017 2018 2019
# BR2_PACKAGE_QLIBC is not set

#
# Security
#
# BR2_PACKAGE_LIBSELINUX is not set
# BR2_PACKAGE_LIBSEMANAGE is not set
# BR2_PACKAGE_LIBSEPOL is not set
2020 2021 2022 2023 2024 2025

#
# Text and terminal handling
#

#
2026
# enchant needs a toolchain w/ C++, threads, wchar
2027 2028 2029
#

#
2030
# icu needs a toolchain w/ C++, wchar, threads
2031
#
2032 2033 2034 2035 2036
# BR2_PACKAGE_LIBCLI is not set
# BR2_PACKAGE_LIBEDIT is not set
# BR2_PACKAGE_LIBENCA is not set
BR2_PACKAGE_LIBESTR=y
# BR2_PACKAGE_LIBFRIBIDI is not set
2037
# BR2_PACKAGE_LIBICONV is not set
2038 2039
# BR2_PACKAGE_LIBUNISTRING is not set
# BR2_PACKAGE_LINENOISE is not set
2040
BR2_PACKAGE_NCURSES=y
2041
# BR2_PACKAGE_NCURSES_WCHAR is not set
2042
BR2_PACKAGE_NCURSES_TARGET_PANEL=y
2043
# BR2_PACKAGE_NCURSES_TARGET_FORM is not set
2044
BR2_PACKAGE_NCURSES_TARGET_MENU=y
2045
# BR2_PACKAGE_NCURSES_TARGET_PROGS is not set
2046
# BR2_PACKAGE_NEWT is not set
2047
BR2_PACKAGE_PCRE=y
2048 2049 2050 2051 2052
# BR2_PACKAGE_PCRE_16 is not set
# BR2_PACKAGE_PCRE_32 is not set
# BR2_PACKAGE_PCRE_UTF is not set
# BR2_PACKAGE_PCRE_UCP is not set
BR2_PACKAGE_POPT=y
2053
BR2_PACKAGE_READLINE=y
2054 2055 2056
# BR2_PACKAGE_SLANG is not set

#
2057
# tclap needs a toolchain w/ C++
2058
#
2059
# BR2_PACKAGE_USTR is not set
2060 2061

#
2062
# Mail
2063
#
2064 2065 2066 2067 2068 2069 2070
# BR2_PACKAGE_DOVECOT is not set
# BR2_PACKAGE_EXIM is not set
# BR2_PACKAGE_FETCHMAIL is not set
# BR2_PACKAGE_HEIRLOOM_MAILX is not set
# BR2_PACKAGE_LIBESMTP is not set
# BR2_PACKAGE_MSMTP is not set
# BR2_PACKAGE_MUTT is not set
2071 2072

#
2073
# Miscellaneous
2074
#
2075 2076 2077 2078 2079 2080 2081 2082 2083 2084 2085 2086 2087 2088 2089 2090 2091
# BR2_PACKAGE_AESPIPE is not set
# BR2_PACKAGE_BC is not set
# BR2_PACKAGE_CLAMAV is not set
# BR2_PACKAGE_COLLECTD is not set
# BR2_PACKAGE_EMPTY is not set

#
# gnuradio needs a toolchain w/ C++, NPTL, wchar, dynamic library
#
# BR2_PACKAGE_GOOGLEFONTDIRECTORY is not set
# BR2_PACKAGE_HAVEGED is not set
# BR2_PACKAGE_MCRYPT is not set
# BR2_PACKAGE_MOBILE_BROADBAND_PROVIDER_INFO is not set

#
# qpdf needs a toolchain w/ C++
#
2092
# BR2_PACKAGE_SHARED_MIME_INFO is not set
2093 2094
# BR2_PACKAGE_SNOWBALL_INIT is not set
# BR2_PACKAGE_XUTIL_UTIL_MACROS is not set
2095 2096

#
2097 2098
# Networking applications
#
2099 2100 2101
# BR2_PACKAGE_AICCU is not set
# BR2_PACKAGE_AIRCRACK_NG is not set
# BR2_PACKAGE_APACHE is not set
2102
# BR2_PACKAGE_ARGUS is not set
2103 2104 2105
# BR2_PACKAGE_ARPTABLES is not set
# BR2_PACKAGE_ATFTP is not set
# BR2_PACKAGE_AUTOSSH is not set
2106 2107
# BR2_PACKAGE_AVAHI is not set
# BR2_PACKAGE_AXEL is not set
2108 2109
# BR2_PACKAGE_BANDWIDTHD is not set
# BR2_PACKAGE_BATCTL is not set
2110 2111

#
2112
# bcusdk needs a toolchain w/ C++
2113
#
2114 2115
# BR2_PACKAGE_BIND is not set
# BR2_PACKAGE_BLUEZ_UTILS is not set
2116 2117

#
2118
# bluez5-utils needs a glibc or musl toolchain w/ wchar, threads, headers >= 3.4, dynamic library
2119
#
2120 2121
# BR2_PACKAGE_BMON is not set
# BR2_PACKAGE_BOA is not set
2122 2123
BR2_PACKAGE_BRIDGE_UTILS=y
# BR2_PACKAGE_BWM_NG is not set
2124
# BR2_PACKAGE_C_ICAP is not set
2125
# BR2_PACKAGE_CAN_UTILS is not set
2126 2127 2128 2129 2130
# BR2_PACKAGE_CHRONY is not set
# BR2_PACKAGE_CIVETWEB is not set
# BR2_PACKAGE_CONNMAN is not set
# BR2_PACKAGE_CONNTRACK_TOOLS is not set
# BR2_PACKAGE_CRDA is not set
2131 2132

#
2133 2134 2135 2136 2137
# ctorrent needs a toolchain w/ C++
#

#
# cups needs a toolchain w/ C++
2138
#
2139
# BR2_PACKAGE_DHCP is not set
2140
# BR2_PACKAGE_DHCPCD is not set
2141
BR2_PACKAGE_DHCPDUMP=y
2142
# BR2_PACKAGE_DNSMASQ is not set
2143
# BR2_PACKAGE_DRBD_UTILS is not set
2144
BR2_PACKAGE_DROPBEAR=y
2145
BR2_PACKAGE_DROPBEAR_CLIENT=y
2146 2147 2148 2149
BR2_PACKAGE_DROPBEAR_DISABLE_REVERSEDNS=y
BR2_PACKAGE_DROPBEAR_SMALL=y
# BR2_PACKAGE_DROPBEAR_WTMP is not set
# BR2_PACKAGE_DROPBEAR_LASTLOG is not set
2150
# BR2_PACKAGE_EBTABLES is not set
2151 2152

#
2153
# ejabberd needs erlang
2154 2155
#
BR2_PACKAGE_ETHTOOL=y
2156 2157 2158 2159 2160 2161 2162 2163 2164 2165
# BR2_PACKAGE_FAIFA is not set
# BR2_PACKAGE_FASTD is not set
# BR2_PACKAGE_FCGIWRAP is not set
# BR2_PACKAGE_FPING is not set
# BR2_PACKAGE_GESFTPSERVER is not set

#
# hans needs a toolchain w/ C++
#
# BR2_PACKAGE_HIAWATHA is not set
2166
# BR2_PACKAGE_HOSTAPD is not set
2167 2168 2169 2170 2171 2172 2173 2174 2175
# BR2_PACKAGE_HTTPING is not set

#
# ibrdtn-tools needs a toolchain w/ C++, threads
#

#
# ibrdtnd needs a toolchain w/ C++, threads
#
2176
# BR2_PACKAGE_IFPLUGD is not set
2177
# BR2_PACKAGE_IFTOP is not set
2178 2179

#
2180
# ifupdown needs an (e)glibc or musl toolchain w/ headers >= 3.0
2181 2182 2183
#

#
2184 2185 2186 2187 2188 2189 2190 2191
# igh-ethercat needs a Linux kernel to be built
#
# BR2_PACKAGE_IGMPPROXY is not set
# BR2_PACKAGE_INADYN is not set
# BR2_PACKAGE_IODINE is not set

#
# iperf needs a toolchain w/ C++
2192
#
2193 2194 2195 2196
# BR2_PACKAGE_IPERF3 is not set
BR2_PACKAGE_IPROUTE2=y
# BR2_PACKAGE_IPSEC_TOOLS is not set
# BR2_PACKAGE_IPSET is not set
2197
# BR2_PACKAGE_IPTABLES is not set
2198 2199 2200
# BR2_PACKAGE_IPTRAF_NG is not set
# BR2_PACKAGE_IPUTILS is not set
# BR2_PACKAGE_IRSSI is not set
2201
# BR2_PACKAGE_IW is not set
2202 2203 2204 2205 2206 2207 2208
# BR2_PACKAGE_JANUS_GATEWAY is not set

#
# kismet needs a toolchain w/ threads, C++, dynamic library
#
# BR2_PACKAGE_KNOCK is not set
# BR2_PACKAGE_LEAFNODE2 is not set
2209 2210

#
2211
# lftp requires a toolchain w/ C++, wchar
2212
#
2213 2214 2215 2216 2217 2218
BR2_PACKAGE_LIGHTTPD=y
# BR2_PACKAGE_LIGHTTPD_OPENSSL is not set
BR2_PACKAGE_LIGHTTPD_ZLIB=y
# BR2_PACKAGE_LIGHTTPD_BZIP2 is not set
BR2_PACKAGE_LIGHTTPD_PCRE=y
# BR2_PACKAGE_LIGHTTPD_WEBDAV is not set
2219 2220 2221 2222

#
# linknx needs a toolchain w/ C++
#