Commit de901a24 authored by Adam Wujek's avatar Adam Wujek Committed by Maciej Lipinski

configs/buildroot: use full version of logger from util-linux

Uplift util-linux to a version 2.28.2
Signed-off-by: Adam Wujek's avatarAdam Wujek <adam.wujek@cern.ch>
parent fc96052f
......@@ -2493,7 +2493,55 @@ BR2_PACKAGE_SYSTEMD_ARCH_SUPPORTS=y
# BR2_PACKAGE_TAR is not set
# BR2_PACKAGE_TPM_TOOLS is not set
# BR2_PACKAGE_UNSCD is not set
# BR2_PACKAGE_UTIL_LINUX is not set
BR2_PACKAGE_UTIL_LINUX=y
# BR2_PACKAGE_UTIL_LINUX_LIBBLKID is not set
# BR2_PACKAGE_UTIL_LINUX_LIBMOUNT is not set
# BR2_PACKAGE_UTIL_LINUX_LIBSMARTCOLS is not set
# BR2_PACKAGE_UTIL_LINUX_LIBUUID is not set
# BR2_PACKAGE_UTIL_LINUX_BINARIES is not set
# BR2_PACKAGE_UTIL_LINUX_AGETTY is not set
# BR2_PACKAGE_UTIL_LINUX_BFS is not set
# BR2_PACKAGE_UTIL_LINUX_CHFN_CHSH is not set
# BR2_PACKAGE_UTIL_LINUX_CRAMFS is not set
# BR2_PACKAGE_UTIL_LINUX_EJECT is not set
# BR2_PACKAGE_UTIL_LINUX_FALLOCATE is not set
# BR2_PACKAGE_UTIL_LINUX_FDFORMAT is not set
# BR2_PACKAGE_UTIL_LINUX_FINDFS is not set
# BR2_PACKAGE_UTIL_LINUX_FSCK is not set
# BR2_PACKAGE_UTIL_LINUX_HWCLOCK is not set
# BR2_PACKAGE_UTIL_LINUX_KILL is not set
BR2_PACKAGE_UTIL_LINUX_LOGGER=y
# BR2_PACKAGE_UTIL_LINUX_LAST is not set
# BR2_PACKAGE_UTIL_LINUX_LINE is not set
# BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS is not set
# BR2_PACKAGE_UTIL_LINUX_LOSETUP is not set
# BR2_PACKAGE_UTIL_LINUX_MESG is not set
# BR2_PACKAGE_UTIL_LINUX_MINIX is not set
# BR2_PACKAGE_UTIL_LINUX_MORE is not set
# BR2_PACKAGE_UTIL_LINUX_MOUNT is not set
# BR2_PACKAGE_UTIL_LINUX_MOUNTPOINT is not set
# BR2_PACKAGE_UTIL_LINUX_NEWGRP is not set
# BR2_PACKAGE_UTIL_LINUX_NOLOGIN is not set
# BR2_PACKAGE_UTIL_LINUX_NSENTER is not set
# BR2_PACKAGE_UTIL_LINUX_PARTX is not set
# BR2_PACKAGE_UTIL_LINUX_PIVOT_ROOT is not set
# BR2_PACKAGE_UTIL_LINUX_RAW is not set
# BR2_PACKAGE_UTIL_LINUX_RENAME is not set
# BR2_PACKAGE_UTIL_LINUX_RESET is not set
# BR2_PACKAGE_UTIL_LINUX_SCHEDUTILS is not set
# BR2_PACKAGE_UTIL_LINUX_SETPRIV is not set
# BR2_PACKAGE_UTIL_LINUX_SETTERM is not set
# BR2_PACKAGE_UTIL_LINUX_SWITCH_ROOT is not set
# BR2_PACKAGE_UTIL_LINUX_TUNELP is not set
# BR2_PACKAGE_UTIL_LINUX_UL is not set
# BR2_PACKAGE_UTIL_LINUX_UNSHARE is not set
# BR2_PACKAGE_UTIL_LINUX_UTMPDUMP is not set
# BR2_PACKAGE_UTIL_LINUX_UUIDD is not set
# BR2_PACKAGE_UTIL_LINUX_VIPW is not set
# BR2_PACKAGE_UTIL_LINUX_WALL is not set
# BR2_PACKAGE_UTIL_LINUX_WDCTL is not set
# BR2_PACKAGE_UTIL_LINUX_WRITE is not set
# BR2_PACKAGE_UTIL_LINUX_ZRAMCTL is not set
#
# Text editors and viewers
......
......@@ -1066,4 +1066,4 @@ CONFIG_FEATURE_IPC_SYSLOG_BUFFER_SIZE=0
# CONFIG_FEATURE_KMSG_SYSLOG is not set
CONFIG_KLOGD=y
CONFIG_FEATURE_KLOGD_KLOGCTL=y
CONFIG_LOGGER=y
# CONFIG_LOGGER is not set
From 0ac0b7ea8ea26d0637aeb0c046e936e71e283b45 Mon Sep 17 00:00:00 2001
From: Adam Wujek <adam.wujek@cern.ch>
Date: Wed, 5 Jun 2019 10:22:51 +0200
Subject: [PATCH] util-linux uplift to version 2.28.2
Signed-off-by: Adam Wujek <adam.wujek@cern.ch>
---
package/util-linux/util-linux.hash | 4 ++--
package/util-linux/util-linux.mk | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/package/util-linux/util-linux.hash b/package/util-linux/util-linux.hash
index de60823..340ee94 100644
--- a/package/util-linux/util-linux.hash
+++ b/package/util-linux/util-linux.hash
@@ -1,2 +1,2 @@
-# From https://www.kernel.org/pub/linux/utils/util-linux/v2.27/sha256sums.asc
-sha256 0a818fcdede99aec43ffe6ca5b5388bff80d162f2f7bd4541dca94fecb87a290 util-linux-2.27.1.tar.xz
+# From https://www.kernel.org/pub/linux/utils/util-linux/v2.28/sha256sums.asc
+sha256 b89d37146f20bede93a42c847bce881a17e6dbd8066ff2db2bee733fa409f0cd util-linux-2.28.2.tar.xz
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index 7342174..da03c99 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -4,8 +4,8 @@
#
################################################################################
-UTIL_LINUX_VERSION = $(UTIL_LINUX_VERSION_MAJOR).1
-UTIL_LINUX_VERSION_MAJOR = 2.27
+UTIL_LINUX_VERSION = $(UTIL_LINUX_VERSION_MAJOR).2
+UTIL_LINUX_VERSION_MAJOR = 2.28
UTIL_LINUX_SOURCE = util-linux-$(UTIL_LINUX_VERSION).tar.xz
UTIL_LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/util-linux/v$(UTIL_LINUX_VERSION_MAJOR)
--
2.17.1
From 26e89066afd1470783945853b957f5c6a0ce8691 Mon Sep 17 00:00:00 2001
From: Adam Wujek <adam.wujek@cern.ch>
Date: Wed, 5 Jun 2019 11:45:05 +0200
Subject: [PATCH] util-linux: remove not needed patches
Signed-off-by: Adam Wujek <adam.wujek@cern.ch>
---
...ipw-Remove-pre-ANSI-compiler-support.patch | 35 ------------
.../0005-build-sys-use-REALTIME_LIBS.patch | 41 --------------
...ix-static-configuration-and-building.patch | 54 -------------------
.../util-linux/0007-build-sys-fix-typo.patch | 34 ------------
4 files changed, 164 deletions(-)
delete mode 100644 package/util-linux/0004-vipw-Remove-pre-ANSI-compiler-support.patch
delete mode 100644 package/util-linux/0005-build-sys-use-REALTIME_LIBS.patch
delete mode 100644 package/util-linux/0006-buildsys-fix-static-configuration-and-building.patch
delete mode 100644 package/util-linux/0007-build-sys-fix-typo.patch
diff --git a/package/util-linux/0004-vipw-Remove-pre-ANSI-compiler-support.patch b/package/util-linux/0004-vipw-Remove-pre-ANSI-compiler-support.patch
deleted file mode 100644
index 3a0c42a..0000000
--- a/package/util-linux/0004-vipw-Remove-pre-ANSI-compiler-support.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 9ce534491aea9b7975cfee5064423d0b850d8002 Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@openwide.fr>
-Date: Sun, 9 Aug 2015 11:20:00 +0200
-Subject: [PATCH] vipw: Remove pre-ANSI compiler support
-
-__P() is used for compatibility with old K&R C compilers. With
-ANSI C this macro has no effect.
-
-This fixes a compilation error with musl libc because of undeclared
-__P.
-
-Ref:
-https://lists.samba.org/archive/samba-technical/2015-June/108042.html
-
-Signed-off-by: Romain Naour <romain.naour@openwide.fr>
----
- login-utils/vipw.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/login-utils/vipw.c b/login-utils/vipw.c
-index 668f4d8..e4c803b 100644
---- a/login-utils/vipw.c
-+++ b/login-utils/vipw.c
-@@ -85,7 +85,7 @@ int program;
- char orig_file[FILENAMELEN]; /* original file /etc/passwd or /etc/group */
- char *tmp_file; /* tmp file */
-
--void pw_error __P((char *, int, int));
-+void pw_error (char *, int, int);
-
- static void copyfile(int from, int to)
- {
---
-2.4.3
-
diff --git a/package/util-linux/0005-build-sys-use-REALTIME_LIBS.patch b/package/util-linux/0005-build-sys-use-REALTIME_LIBS.patch
deleted file mode 100644
index 6402ef5..0000000
--- a/package/util-linux/0005-build-sys-use-REALTIME_LIBS.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 9ed54668c15534a3b9d75e8a3e90b72ea426e596 Mon Sep 17 00:00:00 2001
-From: Karel Zak <kzak@redhat.com>
-Date: Fri, 9 Oct 2015 11:31:49 +0200
-Subject: [PATCH] build-sys: use REALTIME_LIBS
-
-Signed-off-by: Karel Zak <kzak@redhat.com>
----
- misc-utils/Makemodule.am | 2 +-
- sys-utils/Makemodule.am | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/misc-utils/Makemodule.am b/misc-utils/Makemodule.am
-index e801611..b96d18b 100644
---- a/misc-utils/Makemodule.am
-+++ b/misc-utils/Makemodule.am
-@@ -90,7 +90,7 @@ endif
- if BUILD_UUIDD
- usrsbin_exec_PROGRAMS += uuidd
- dist_man_MANS += misc-utils/uuidd.8
--uuidd_LDADD = $(LDADD) libuuid.la libcommon.la
-+uuidd_LDADD = $(LDADD) libuuid.la libcommon.la $(REALTIME_LIBS)
- uuidd_CFLAGS = $(DAEMON_CFLAGS) $(AM_CFLAGS) -I$(ul_libuuid_incdir)
- uuidd_LDFLAGS = $(DAEMON_LDFLAGS) $(AM_LDFLAGS)
- uuidd_SOURCES = misc-utils/uuidd.c
-
-diff --git a/sys-utils/Makemodule.am b/sys-utils/Makemodule.am
-index f306e65..3d28ff1 100644
---- a/sys-utils/Makemodule.am
-+++ b/sys-utils/Makemodule.am
-@@ -2,7 +2,7 @@ if BUILD_FLOCK
- usrbin_exec_PROGRAMS += flock
- dist_man_MANS += sys-utils/flock.1
- flock_SOURCES = sys-utils/flock.c lib/monotonic.c lib/timer.c
--flock_LDADD = $(LDADD) libcommon.la -lrt
-+flock_LDADD = $(LDADD) libcommon.la $(REALTIME_LIBS)
- endif
-
- if BUILD_IPCMK
---
-2.5.0
-
diff --git a/package/util-linux/0006-buildsys-fix-static-configuration-and-building.patch b/package/util-linux/0006-buildsys-fix-static-configuration-and-building.patch
deleted file mode 100644
index cd5654e..0000000
--- a/package/util-linux/0006-buildsys-fix-static-configuration-and-building.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From f69e18629d1c91d83ab91314baf5e34088b57f6e Mon Sep 17 00:00:00 2001
-From: Lada Trimasova <ltrimas@synopsys.com>
-Date: Wed, 27 Jan 2016 16:26:41 +0300
-Subject: [PATCH] buildsys: fix static configuration and building
-
-In case of uClibc librt depends on libpthread. In particular
-timer_create() function uses pthread_XXX(). That means in case
-of static builds it's required to link not librt alone but
-together with libpthread. So if checking timer_create function
-in librt fails, it is necessary to check if timer_create function
-successfully links with "-lpthread".
-
-That issues was spotted in Buldroot autobuilder failures:
-http://autobuild.buildroot.net/results/759/75960db671807091fe9155aee9e46a6245e32590/
-http://autobuild.buildroot.org/results/112/112e8b85783f5aaba42a937a6eb064317615a21b/
-
-Signed-off-by: Lada Trimasova <ltrimas@synopsys.com>
----
- configure.ac | 13 +++++++++++--
- 1 file changed, 11 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 56512c0..9392bf2 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -382,14 +382,23 @@ AC_CHECK_FUNCS([clock_gettime], [],
- AC_SUBST([REALTIME_LIBS])
-
- have_timer="no"
--AC_CHECK_FUNCS([timer_createx],
-+AC_CHECK_FUNCS([timer_create],
- [have_time="yes"],
- [AC_CHECK_LIB([rt], [timer_create], [
- have_timer="yes"
- REALTIME_LIBS="-lrt"
-- ])]
-+ ],[
-+ AC_SEARCH_LIBS([timer_create], [rt], [
-+ AC_MSG_RESULT(yes)
-+ have_timer="yes"
-+ REALTIME_LIBS="-lrt -lpthread"
-+ ],[], [-lpthread]
-+ )
-+ ])]
- )
-
-+AC_SUBST([REALTIME_LIBS])
-+
-
- AC_CHECK_MEMBER([struct sockaddr.sa_len],
- AC_DEFINE_UNQUOTED([HAVE_SA_LEN], [1], [Define if struct sockaddr contains sa_len]), [],
---
-2.5.0
-
diff --git a/package/util-linux/0007-build-sys-fix-typo.patch b/package/util-linux/0007-build-sys-fix-typo.patch
deleted file mode 100644
index 204c3d8..0000000
--- a/package/util-linux/0007-build-sys-fix-typo.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From dea1bd2917ed9490ee96162288e0904e3de9da2d Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@gmail.com>
-Date: Tue, 16 Feb 2016 00:24:30 +0100
-Subject: [PATCH] build-sys: fix typo
-
-When timer_create is available have_timer must be
-set to "yes". But instead have_time is used.
-
-Replace have_time by have_timer.
-
-Fixes:
-http://autobuild.buildroot.net/results/993/9935cd0522d4f978ba2e788a690f66790686b76b
-
-Signed-off-by: Romain Naour <romain.naour@gmail.com>
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 4559573..3950f0c 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -390,7 +390,7 @@ AC_CHECK_FUNCS([clock_gettime], [],
-
- have_timer="no"
- AC_CHECK_FUNCS([timer_create],
-- [have_time="yes"],
-+ [have_timer="yes"],
- [AC_CHECK_LIB([rt], [timer_create], [
- have_timer="yes"
- REALTIME_LIBS="-lrt"
---
-2.5.0
-
--
2.17.1
From 196434f1679389f68d2fbbb392a4f93b70dc4a04 Mon Sep 17 00:00:00 2001
From: Adam Wujek <adam.wujek@cern.ch>
Date: Wed, 5 Jun 2019 10:25:46 +0200
Subject: [PATCH] util-linux: add selection of logger
Signed-off-by: Adam Wujek <adam.wujek@cern.ch>
---
package/util-linux/Config.in | 5 +++++
package/util-linux/util-linux.mk | 1 +
2 files changed, 6 insertions(+)
diff --git a/package/util-linux/Config.in b/package/util-linux/Config.in
index 60abd67..7d50aba 100644
--- a/package/util-linux/Config.in
+++ b/package/util-linux/Config.in
@@ -112,6 +112,11 @@ config BR2_PACKAGE_UTIL_LINUX_KILL
help
Send a signal to a process
+config BR2_PACKAGE_UTIL_LINUX_LOGGER
+ bool "logger"
+ help
+ Enter messages into the system log
+
config BR2_PACKAGE_UTIL_LINUX_LAST
bool "last"
help
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index da03c99..41dfc32 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -83,6 +83,7 @@ UTIL_LINUX_CONF_OPTS += \
$(if $(BR2_PACKAGE_UTIL_LINUX_LIBSMARTCOLS),--enable-libsmartcols,--disable-libsmartcols) \
$(if $(BR2_PACKAGE_UTIL_LINUX_LIBUUID),--enable-libuuid,--disable-libuuid) \
$(if $(BR2_PACKAGE_UTIL_LINUX_LINE),--enable-line,--disable-line) \
+ $(if $(BR2_PACKAGE_UTIL_LINUX_LOGGER),--enable-logger,--disable-logger) \
$(if $(BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS),--enable-last --enable-login --enable-runuser --enable-su --enable-sulogin,--disable-last --disable-login --disable-runuser --disable-su --disable-sulogin) \
$(if $(BR2_PACKAGE_UTIL_LINUX_LOSETUP),--enable-losetup,--disable-losetup) \
$(if $(BR2_PACKAGE_UTIL_LINUX_MESG),--enable-mesg,--disable-mesg) \
--
2.17.1
From a6c9c371c49dedc2a75761eb3d1898a9cfcc7863 Mon Sep 17 00:00:00 2001
From: Adam Wujek <adam.wujek@cern.ch>
Date: Tue, 18 Jun 2019 16:47:59 +0200
Subject: [PATCH] util-linux: allow disabling the basic set of tools
Patch based on a patch from buildroot repository:
e8ddc0de util-linux: allow disabling the basic set of tools
When even a single extra util-linux utility is enabled, the default
build and install will install many more programs, including many that
overlap with those offered by busybox.
Fix by reworking the install-utilies menu to take advantage of the new
--disable-all-programs config option. This option make it possible to
disable the basic set of apps, and then enable only the desired apps.
Original patch by Danomi Manchego, visible at
http://patchwork.ozlabs.org/patch/494866/
Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
[Thomas/Arnout: remove the choice between all/custom/no, and simply have
a list of options with the basic set of tools, and then one option for
each tool. This gives the same flexibility, but avoids the choice, which
is never nice to have.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Adam Wujek <adam.wujek@cern.ch>
---
package/util-linux/Config.in | 6 +-----
package/util-linux/util-linux.mk | 7 +------
2 files changed, 2 insertions(+), 11 deletions(-)
diff --git a/package/util-linux/Config.in b/package/util-linux/Config.in
index 7d50aba..fa09384 100644
--- a/package/util-linux/Config.in
+++ b/package/util-linux/Config.in
@@ -37,7 +37,7 @@ config BR2_PACKAGE_UTIL_LINUX_LIBUUID
Install libuuid.
config BR2_PACKAGE_UTIL_LINUX_BINARIES
- bool "install utilities"
+ bool "basic set"
depends on BR2_USE_MMU # fork()
select BR2_PACKAGE_UTIL_LINUX_LIBBLKID
select BR2_PACKAGE_UTIL_LINUX_LIBMOUNT
@@ -46,8 +46,6 @@ config BR2_PACKAGE_UTIL_LINUX_BINARIES
help
Install the basic set of util-linux binaries.
-if BR2_PACKAGE_UTIL_LINUX_BINARIES
-
config BR2_PACKAGE_UTIL_LINUX_AGETTY
bool "agetty"
help
@@ -292,7 +290,5 @@ config BR2_PACKAGE_UTIL_LINUX_ZRAMCTL
endif
-endif
-
comment "util-linux needs a toolchain w/ wchar"
depends on !BR2_USE_WCHAR
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index 41dfc32..5b81786 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -66,6 +66,7 @@ UTIL_LINUX_DEPENDENCIES += $(if $(BR2_PACKAGE_LINUX_PAM),linux-pam)
# Disable/Enable utilities
UTIL_LINUX_CONF_OPTS += \
+ $(if $(BR2_PACKAGE_UTIL_LINUX_BINARIES),--enable-all-programs,--disable-all-programs) \
$(if $(BR2_PACKAGE_UTIL_LINUX_AGETTY),--enable-agetty,--disable-agetty) \
$(if $(BR2_PACKAGE_UTIL_LINUX_BFS),--enable-bfs,--disable-bfs) \
$(if $(BR2_PACKAGE_UTIL_LINUX_CHFN_CHSH),--enable-chfn-chsh,--disable-chfn-chsh) \
@@ -131,12 +132,6 @@ else
HOST_UTIL_LINUX_CONF_OPTS += --disable-all-programs
endif
-# Avoid building the tools if they are disabled since we can't install on
-# a per-directory basis.
-ifeq ($(BR2_PACKAGE_UTIL_LINUX_BINARIES),)
-UTIL_LINUX_CONF_OPTS += --disable-all-programs
-endif
-
# Install libmount Python bindings
ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
UTIL_LINUX_CONF_OPTS += --with-python
--
2.17.1
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment