Add ObsBox software recipe

parent 8f093094
diff --git a/tools/Makefile b/tools/Makefile
index 8400b15..ef809c8 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -18,5 +18,8 @@ all: $(progs)
clean:
rm -f $(progs) *~ *.o
+modules_install:
+ echo "This is a dummy target for BitBake"
+
%: %.c
$(CC) $(CFLAGS) $^ -o $@
SUMMARY = "Software support for the ObsBox SPEC design"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
inherit module
PR = "r0"
PV = "0.1"
SRC_URI = "gitsm://github.com/FedericoVaga/obs-box-sw.git \
file://001-obsbox_tools.patch"
SRCREV = "2d49db5ca1397bc020de071116a0d5080f6f580c"
S = "${WORKDIR}/git"
#export CROSS_COMPILE_SYSROOT = "${STAGING_DIR_TARGET}"
do_compile(){
make
}
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment